summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:27:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:27:28 +0300
commit63c3f15dc2ff51f87c23bf9c7fd0cb5d3b9c5569 (patch)
treea539e7f94e9ff366aaf4c4ae507095248bed0a4d /gnu/packages/django.scm
parente1302edbd9f8b333a2add8cfcbca82636c3ca0af (diff)
downloadguix-patches-63c3f15dc2ff51f87c23bf9c7fd0cb5d3b9c5569.tar
guix-patches-63c3f15dc2ff51f87c23bf9c7fd0cb5d3b9c5569.tar.gz
gnu: Add python-django-q.
* gnu/packages/django.scm (python-django-q): New variable.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 55cc869fc4..56b00c8d9a 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -831,6 +831,41 @@ settings.py and easily use them in your project.")
(define-public python2-django-rq
(package-with-python2 python-django-rq))
+(define-public python-django-q
+ (package
+ (name "python-django-q")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-q" version))
+ (sha256
+ (base32
+ "0ac3rjxv37bn97a62ly8b7qvbv765z6paiinzpwxx83nal2icc42"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "DJANGO_SETTINGS_MODULE" "django_q.tests.settings")
+ (invoke "django-admin" "test" "django_q.tests"
+ "--pythonpath=."))))))
+ (propagated-inputs
+ `(("python-arrow" ,python-arrow)
+ ("python-blessed" ,python-blessed)
+ ("python-django" ,python-django)
+ ("python-django-picklefield" ,python-django-picklefield)))
+ (native-inputs
+ `(("python-django-redis" ,python-django-redis)
+ ("python-pytest-django" ,python-pytest-django)))
+ (home-page "https://django-q.readthedocs.io/")
+ (synopsis "Multiprocessing distributed task queue for Django")
+ (description
+ "Django Q is a native Django task queue, scheduler and worker application
+using Python multiprocessing.")
+ (license license:expat)))
+
(define-public python-django-sortedm2m
(package
(name "python-django-sortedm2m")