summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 17:38:12 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:59 +0200
commit5bbc98a35d955571422b23aafed895ea95fe0cf0 (patch)
tree609e6bebc497cf5253ca90f8e3ddb2e86dc49c52 /gnu/packages/django.scm
parent28e997e88b692fde9ba5c61213b26962cb473c95 (diff)
downloadguix-patches-5bbc98a35d955571422b23aafed895ea95fe0cf0.tar
guix-patches-5bbc98a35d955571422b23aafed895ea95fe0cf0.tar.gz
gnu: Add python-django-debug-toolbar-alchemy.
* gnu/packages/django.scm (python-django-debug-toolbar-alchemy): New public variable.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 43d73de2f1..6953f8d0d3 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -504,6 +504,32 @@ account authentication.")
request and response as a toolbar on the rendered page.")
(license license:bsd-3)))
+(define-public python-django-debug-toolbar-alchemy
+ (package
+ (name "python-django-debug-toolbar-alchemy")
+ (version "0.1.5")
+ (home-page "https://github.com/miki725/django-debug-toolbar-alchemy")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-debug-toolbar-alchemy" version))
+ (sha256
+ (base32
+ "1kmpzghnsc247bc1dl22s4y62k9ijgy1pjms227018h5a4frsa5b"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;XXX: 'make check' does "echo TODO"
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-django-debug-toolbar" ,python-django-debug-toolbar)
+ ("python-jsonplus" ,python-jsonplus)
+ ("python-six" ,python-six)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (synopsis "Django Debug Toolbar panel for SQLAlchemy")
+ (description
+ "This package completely mimics the default Django Debug Toolbar SQL
+panel (internally it is actually subclassed), but instead of displaying
+queries done via the Django ORM, SQLAlchemy generated queries are displayed.")
+ (license license:expat)))
+
(define-public python-django-gravatar2
(package
(name "python-django-gravatar2")