summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 14:25:26 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:56 +0200
commit27f32604d4efb3a147606c6ac4221831dc3502e2 (patch)
tree7628d3fef0c44be63f6a69893d6b5476ab86c2eb /gnu/packages/django.scm
parentda6448cda54ad3ef615953e7fa80782e46e4d05d (diff)
downloadguix-patches-27f32604d4efb3a147606c6ac4221831dc3502e2.tar
guix-patches-27f32604d4efb3a147606c6ac4221831dc3502e2.tar.gz
gnu: python-django-q: Update to 1.3.3.
* gnu/packages/django.scm (python-django-q): Update to 1.3.3. [arguments]: Add #:tests?. Remove #:phases. [native-inputs]: Remove.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 38dd2843c5..e2b2336436 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -950,31 +950,22 @@ settings.py and easily use them in your project.")
(define-public python-django-q
(package
(name "python-django-q")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "django-q" version))
(sha256
(base32
- "0ac3rjxv37bn97a62ly8b7qvbv765z6paiinzpwxx83nal2icc42"))))
+ "1fs29767940akbsn3vdzw2rqnn9v77b0b55bi7fvydny1rk7fw6y"))))
(build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "DJANGO_SETTINGS_MODULE" "django_q.tests.settings")
- (invoke "django-admin" "test" "django_q.tests"
- "--pythonpath=."))))))
+ ;; FIXME: Tests require disque, Redis, MongoDB, Docker.
+ (arguments '(#:tests? #f))
(propagated-inputs
`(("python-arrow" ,python-arrow)
("python-blessed" ,python-blessed)
("python-django" ,python-django)
("python-django-picklefield" ,python-django-picklefield)))
- (native-inputs
- `(("python-django-redis" ,python-django-redis)
- ("python-pytest-django" ,python-pytest-django)))
(home-page "https://django-q.readthedocs.io/")
(synopsis "Multiprocessing distributed task queue for Django")
(description