summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-11 18:52:45 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:59 +0200
commit18eea4499f4ab6cbd71ce66003e33927bf2b4321 (patch)
treeafbbad074724954830f3b2bbf622703ec4483d2b /gnu/packages/django.scm
parent4f1b919156229957a686a9418a4753051f275a37 (diff)
downloadguix-patches-18eea4499f4ab6cbd71ce66003e33927bf2b4321.tar
guix-patches-18eea4499f4ab6cbd71ce66003e33927bf2b4321.tar.gz
gnu: Remove python-django-overextends.
This package does not work with newer versions of Django and its functionality has been superseded by a built-in extends module. * gnu/packages/django.scm (python-django-overextends): Remove variable.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index f9a4a9089e..e1a2548f14 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -750,36 +750,6 @@ used to attach comments to any model, so you can use it for comments on blog
entries, photos, book chapters, or anything else.")
(license license:bsd-3)))
-(define-public python-django-overextends
- (package
- (name "python-django-overextends")
- (version "0.4.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "django-overextends" version))
- (sha256
- (base32
- "0qc2pcf3i56pmfxh2jw7k3pgljd8xzficmkl2541n7bkcbngqfzm"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (invoke "./test_project/manage.py" "test"))))))
- (propagated-inputs
- `(("python-django" ,python-django)))
- (native-inputs
- `(("sphinx-me" ,python-sphinx-me)))
- (home-page "https://github.com/stephenmcd/django-overextends")
- (synopsis "Circular template inheritance")
- (description
- "A Django reusable app providing the overextends template tag, a drop-in
-replacement for Django's extends tag, which allows you to use circular template
-inheritance. The primary use-case for overextends is to simultaneously
-override and extend templates from other reusable apps, in your own Django
-project.")
- (license license:bsd-2)))
-
(define-public python-django-pipeline
(package
(name "python-django-pipeline")