summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-03 21:50:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-03 21:51:16 -0400
commita8f53d544b00ba80f98c1c65e3cb67ce9110ae93 (patch)
tree3d6b92fabaac79363a3ffb5d94609cbee6b4be8f /gnu/packages/display-managers.scm
parente1375a9b64e3d840cae21197dcf661f9b4d52c85 (diff)
downloadguix-patches-a8f53d544b00ba80f98c1c65e3cb67ce9110ae93.tar
guix-patches-a8f53d544b00ba80f98c1c65e3cb67ce9110ae93.tar.gz
gnu: lightdm: Update to 1.32.0.
* gnu/packages/display-managers.scm (lightdm): Update to 1.32.0.
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm158
1 files changed, 76 insertions, 82 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 264c1a92ec..1ff2bf7ddd 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -255,89 +255,83 @@ experience for your users, your family and yourself")
(license license:gpl3+)))
(define-public lightdm
- ;; Use the latest commit, as the current official release doesn't build with
- ;; glib >= 2.33.
- (let ((revision "0")
- (commit "b7fc3214cbaed09c73e963847443a0d648dfd896"))
- (package
- (name "lightdm")
- (version (git-version "1.30.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/canonical/lightdm")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0378jacazpmdgdjkiilk3mbikz3iysb4s9q40hg9zv4yngwsix1m"))))
- (build-system gnu-build-system)
- (arguments
- '(#:parallel-tests? #f ; fails when run in parallel
- #:configure-flags
- (list "--localstatedir=/var"
- "--enable-gtk-doc"
- ;; Otherwise the test suite fails on such a warning.
- "CFLAGS=-Wno-error=missing-prototypes")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/shared-data-manager.c"
- (("/bin/rm")
- (search-input-file inputs "bin/rm")))
- (substitute* '("data/users.conf"
- "common/user-list.c")
- (("/bin/false")
- (search-input-file inputs "bin/false"))
- (("/usr/sbin/nologin")
- (search-input-file inputs "sbin/nologin")))
- (substitute* "src/seat.c"
- (("/bin/sh")
- (search-input-file inputs "bin/sh")))))
- (add-before 'check 'pre-check
- ;; Run test-suite under a dbus session.
- (lambda _
- (wrap-program "tests/src/test-python-greeter"
- `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
-
- ;; Avoid printing locale warnings, which trip up the text
- ;; matching tests.
- (unsetenv "LC_ALL"))))))
- (inputs
- (list audit
- coreutils ;for cross-compilation
- linux-pam
- shadow ;for sbin/nologin
- libgcrypt
- libxcb
- libxdmcp))
- (native-inputs
- (list accountsservice
- autoconf
- automake
- gobject-introspection
- gtk-doc
- pkg-config
- itstool
- intltool
- libtool
- vala ;for Vala bindings
- ;; For tests
- dbus
- python-wrapper
- python-pygobject
- which
- yelp-tools))
- ;; Required by liblightdm-gobject-1.pc.
- (propagated-inputs
- (list glib libx11 libxklavier))
- (home-page "https://www.freedesktop.org/wiki/Software/LightDM/")
- (synopsis "Lightweight display manager")
- (description "The Light Display Manager (LightDM) is a cross-desktop
+ (package
+ (name "lightdm")
+ (version "1.32.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/canonical/lightdm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wr60c946p8jz9kb8zi4cd8d4mkcy7infbvlfzwajiglc22nblxn"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:parallel-tests? #f ; fails when run in parallel
+ #:configure-flags
+ (list "--localstatedir=/var"
+ "--enable-gtk-doc"
+ ;; Otherwise the test suite fails on such a warning.
+ "CFLAGS=-Wno-error=missing-prototypes")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/shared-data-manager.c"
+ (("/bin/rm")
+ (search-input-file inputs "bin/rm")))
+ (substitute* '("data/users.conf"
+ "common/user-list.c")
+ (("/bin/false")
+ (search-input-file inputs "bin/false"))
+ (("/usr/sbin/nologin")
+ (search-input-file inputs "sbin/nologin")))
+ (substitute* "src/seat.c"
+ (("/bin/sh")
+ (search-input-file inputs "bin/sh")))))
+ (add-before 'check 'pre-check
+ (lambda _
+ (wrap-program "tests/src/test-python-greeter"
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
+ ;; Avoid printing locale warnings, which trip up the text
+ ;; matching tests.
+ (unsetenv "LC_ALL"))))))
+ (inputs
+ (list audit
+ coreutils ;for cross-compilation
+ linux-pam
+ shadow ;for sbin/nologin
+ libgcrypt
+ libxcb
+ libxdmcp))
+ (native-inputs
+ (list accountsservice
+ autoconf
+ automake
+ gobject-introspection
+ gtk-doc
+ pkg-config
+ itstool
+ intltool
+ libtool
+ vala ;for Vala bindings
+ ;; For tests
+ dbus
+ python-wrapper
+ python-pygobject
+ which
+ yelp-tools))
+ ;; Required by liblightdm-gobject-1.pc.
+ (propagated-inputs
+ (list glib libx11 libxklavier))
+ (home-page "https://www.freedesktop.org/wiki/Software/LightDM/")
+ (synopsis "Lightweight display manager")
+ (description "The Light Display Manager (LightDM) is a cross-desktop
display manager which supports different greeters.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public lightdm-gtk-greeter
(package