summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/display-managers.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index a6a1c97360..264ad34ba3 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 L p R n d n <guix@lprndn.info>
;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -158,6 +159,36 @@ Guix's logo. Based on Arch linux's archlinux-simplyblack theme.")
;; Theme under cc-by-sa3.0, guix logo under license:cc-by-sa4.0
(license (list license:cc-by-sa3.0 license:cc-by-sa4.0))))
+(define-public chili-sddm-theme
+ (package
+ (name "chili-sddm-theme")
+ (version "0.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MarianArlt/sddm-chili")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "036fxsa7m8ymmp3p40z671z163y6fcsa9a641lrxdrw225ssq5f3"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (sddm-themes (string-append out "/share/sddm/themes")))
+ (mkdir-p sddm-themes)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ (string-append sddm-themes "/chili"))))))
+ (home-page "https://github.com/MarianArlt/sddm-chili")
+ (synopsis "Chili theme for SDDM")
+ (description "Chili reduces all the clutter and leaves you with a clean,
+easy to use, login interface with a modern yet classy touch.")
+ (license license:gpl3+)))
+
(define-public lightdm
(package
(name "lightdm")