summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 09:07:50 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-26 12:31:39 +0100
commit8ebf4e3a71d945b95fc917fbdde096ef4e07a9e6 (patch)
tree7eb57574cfdc70f952488da7c7e4b387a7d8d19a /gnu/packages/display-managers.scm
parent1a016d9dda8291a7fc5ffd2d10d844d422018513 (diff)
downloadguix-patches-8ebf4e3a71d945b95fc917fbdde096ef4e07a9e6.tar
guix-patches-8ebf4e3a71d945b95fc917fbdde096ef4e07a9e6.tar.gz
gnu: sddm: Fix output directory for QML files.
Path must match qtbase's native-search-path specification, otherwise it will not be picked up by other packages. * gnu/packages/display-managers.scm (sddm)[arguments]<configure-flags>: Change value of "-DQT_IMPORTS_DIR".
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 0b8f742c38..21afc0ec5c 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -102,7 +102,7 @@
(assoc-ref %build-inputs "shadow")
"/etc/login.defs")
(string-append "-DQT_IMPORTS_DIR="
- (assoc-ref %outputs "out") "/qml")
+ (assoc-ref %outputs "out") "/lib/qt5/qml")
(string-append "-DCMAKE_INSTALL_SYSCONFDIR="
(assoc-ref %outputs "out") "/etc"))
#:modules ((guix build cmake-build-system)