summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-08-31 14:07:15 +0100
committerDavid Craven <david@craven.ch>2016-09-01 14:36:49 +0200
commit5fd66a37d58aa13091134d5e6e5f8c62f404ebfe (patch)
treeea780443f044b4c981408058fe093330a4386f99 /gnu/packages/display-managers.scm
parent7060b28171d217b8091b87b92ee55c15f887e890 (diff)
downloadguix-patches-5fd66a37d58aa13091134d5e6e5f8c62f404ebfe.tar
guix-patches-5fd66a37d58aa13091134d5e6e5f8c62f404ebfe.tar.gz
gnu: slim: Move to display-managers.scm.
* gnu/packages/display-managers.scm: New file. * gnu/packages/slim.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/services/xorg.scm: Likewise.
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm95
1 files changed, 95 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
new file mode 100644
index 0000000000..579b149a0c
--- /dev/null
+++ b/gnu/packages/display-managers.scm
@@ -0,0 +1,95 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages display-managers)
+ #:use-module ((guix licenses) #:prefix l:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages linux))
+
+(define-public slim
+ (package
+ (name "slim")
+ (version "1.3.6")
+ (source (origin
+ (method url-fetch)
+ ;; Used to be available from download.berlios.de.
+ (uri (string-append
+ "mirror://sourceforge/slim.berlios/slim-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1pqhk22jb4aja4hkrm7rjgbgzjyh7i4zswdgf5nw862l2znzxpi1"))
+ (patches (search-patches "slim-config.patch"
+ "slim-session.patch"
+ "slim-sigusr1.patch"))))
+ (build-system cmake-build-system)
+ (inputs `(("linux-pam" ,linux-pam)
+ ("libpng" ,libpng)
+ ("libjpeg" ,libjpeg)
+ ("freeglut" ,freeglut)
+ ("libxrandr" ,libxrandr)
+ ("libxrender" ,libxrender)
+ ("freetype" ,freetype)
+ ("fontconfig" ,fontconfig)
+ ("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("libxmu" ,libxmu)
+ ("xauth" ,xauth)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ '(#:phases (alist-cons-before
+ 'configure 'set-new-etc-location
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/etc")
+ (string-append (assoc-ref %outputs "out") "/etc"))
+ (("install.*systemd.*")
+ ;; The build system's logic here is: if "Linux", then
+ ;; "systemd". Strip that.
+ "")))
+ %standard-phases)
+ #:configure-flags '("-DUSE_PAM=yes"
+ "-DUSE_CONSOLEKIT=no")
+ #:tests? #f))
+
+ ;; This used to be at <http://slim.berlios.de/>.
+ (home-page "http://sourceforge.net/projects/slim.berlios/")
+ (synopsis "Desktop-independent graphical login manager for X11")
+ (description
+ "SLiM is a Desktop-independent graphical login manager for X11, derived
+from Login.app. It aims to be light and simple, although completely
+configurable through themes and an option file; is suitable for machines on
+which remote login functionalities are not needed.
+
+Features included: PNG and XFT support for alpha transparency and antialiased
+fonts, External themes support, Configurable runtime options: X server --
+login / shutdown / reboot commands, Single (GDM-like) or double (XDM-like)
+input control, Can load predefined user at startup, Configurable welcome /
+shutdown messages, Random theme selection.")
+ (license l:gpl2)))