summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-02-15 17:42:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-15 18:09:39 +0100
commitb77a690d53f61fd2e878adfeb6c86d2479d22fcf (patch)
treee5d08311a46c743bae7a918c84a95adb0e42e2b3 /gnu/packages/disk.scm
parent3ddb2dec2a45e6674388be101e4d7a6248e358e2 (diff)
downloadguix-patches-b77a690d53f61fd2e878adfeb6c86d2479d22fcf.tar
guix-patches-b77a690d53f61fd2e878adfeb6c86d2479d22fcf.tar.gz
gnu: dosfstools: Fetch sources from git.
* gnu/packages/disk.scm (dosfstools)[source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf & automake.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 110eb83d62..7ad57f1bbb 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -379,19 +379,23 @@ to recover data more efficiently by only reading the necessary blocks.")
(version "4.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/dosfstools/dosfstools"
- "/releases/download/v" version "/"
- "dosfstools-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dosfstools/dosfstools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "09xm1540h9npqw0s5s2335xqxfdp059rl98l3fidr4h0z7mnx4k4"))))
+ (base32 "1xygsixmmc9l7drxylggnzkqqiks8zmlsbhg3z723ii2ak94236s"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-compat-symlinks")
#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")))
(native-inputs
- `(("xxd" ,xxd))) ; for tests
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ;; For tests.
+ ("xxd" ,xxd)))
(home-page "https://github.com/dosfstools/dosfstools")
(synopsis "Utilities for making and checking MS-DOS FAT file systems")
(description