summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-02-05 06:55:04 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 16:55:12 +0800
commitaf06582d6c8596db068c1414ce615c459dde3372 (patch)
tree4d85b6e8cb1e05136b80dae123949065fc473a41 /gnu/packages/disk.scm
parent1755498ca7121abaa8a71de82bd11fbb8b0e912e (diff)
downloadguix-patches-af06582d6c8596db068c1414ce615c459dde3372.tar
guix-patches-af06582d6c8596db068c1414ce615c459dde3372.tar.gz
gnu: parted: Update to 3.4.
* gnu/packages/disk.scm (parted): Update to 3.4. [native-inputs]: Remove python-2 and add python-wrapper to fix tests. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index c9409358db..f02e83a378 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -224,14 +224,14 @@ tmpfs/ramfs filesystems.")
(define-public parted
(package
(name "parted")
- (version "3.3")
+ (version "3.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/parted/parted-"
version ".tar.xz"))
(sha256
(base32
- "0i1xp367wpqw75b20c3jnism3dg3yqj4a7a22p2jb1h1hyyv9qjp"))))
+ "0hjkv84x1bs2qqyx1fnzjqyyqrhv7kpdbq9bgydmi99d8wi80ag1"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -253,7 +253,7 @@ tmpfs/ramfs filesystems.")
;; For the tests.
("e2fsprogs" ,e2fsprogs)
("perl" ,perl)
- ("python" ,python-2)
+ ("python-wrapper" ,python-wrapper)
("util-linux" ,util-linux)))
(home-page "https://www.gnu.org/software/parted/")
(synopsis "Disk partition editor")