summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 15:15:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-13 05:42:56 +0100
commitacc6eb89c81678706c5bc2b3fd1baa0cd604e6b1 (patch)
tree83893cab8273c4d52c20f5e05f2c03a4c3563f7d /gnu/packages/disk.scm
parent3d2386563dea801a8e7ead37d0f60fc38bd5b7a7 (diff)
downloadguix-patches-acc6eb89c81678706c5bc2b3fd1baa0cd604e6b1.tar
guix-patches-acc6eb89c81678706c5bc2b3fd1baa0cd604e6b1.tar.gz
gnu: duperemove: Don't use unstable tarball.
* gnu/packages/disk.scm (duperemove)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 354f00dfa1..55756445af 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -479,15 +479,15 @@ a card with a smaller capacity than stated.")
(package
(name "duperemove")
(version "0.11.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/markfasheh/duperemove/archive/v"
- version ".tar.gz"))
- (sha256
- (base32
- "1j1alh3blbj1wg1zmkpwrf40nggwg8xbgsk2mnn9albymwdwkhvm"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markfasheh/duperemove.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1scz76pvpljvrpfn176125xwaqwyy4pirlm11sc9spb2hyzknw2z"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))