summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-06 09:54:31 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-06 09:58:01 +0200
commita6d78f2bbae64ba0be03c734871035217071112f (patch)
treede86deba2c9551c74223c1df5b50dd4285313fd4 /gnu/packages/disk.scm
parent8a4f1eef98490827b331460d7432de843926869b (diff)
downloadguix-patches-a6d78f2bbae64ba0be03c734871035217071112f.tar
guix-patches-a6d78f2bbae64ba0be03c734871035217071112f.tar.gz
gnu: Add memkind.
* gnu/packages/disk.scm (memkind): New variable.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 1e538ef60e..e598c62257 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1041,3 +1041,46 @@ of choice for all light thinking Unix addicts!")
temperature of your hard drive by reading S.M.A.R.T. information (for drives
that support this feature).")
(license license:gpl2+)))
+
+(define-public memkind
+ (package
+ (name "memkind")
+ (version "1.10.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/memkind/memkind.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "11iz887f3cp5pzf1bzm644wzab8gkbhz3b7x1w6pcps71yd94ylj"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(;; memkind patched jemalloc to add je_arenalookupx,
+ ;; je_check_reallocatex--i.e. they forked jemalloc.
+ ;("jemalloc" ,jemalloc)
+ ("ndctl" ,ndctl)
+ ("numactl" ,numactl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:tests? #f ; Tests require a NUMA-enabled system.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'autogen-jemalloc
+ (lambda _
+ (with-directory-excursion "jemalloc"
+ (substitute* "Makefile.in"
+ (("/bin/sh") (which "sh")))
+ (invoke "autoconf")
+ (substitute* "configure"
+ (("/bin/sh") (which "sh"))))
+ #t)))))
+ (home-page "https://github.com/memkind/memkind")
+ (synopsis "Heap manager with memory kinds (for NUMA)")
+ (description "This package provides a user-extensible heap manager
+built on top of jemalloc which enables control of memory characteristics
+and a partitioning of the heap between kinds of memory (for NUMA).")
+ (license license:bsd-3)))