summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-03-08 01:47:58 +0100
committerLeo Famulari <leo@famulari.name>2016-03-16 02:35:06 -0400
commit8e14e059c40c22b946e7beef64dc9e4d3b3d5e35 (patch)
tree0d1997132c71245ea0803e88686a928338c974cb /gnu/packages/disk.scm
parent892f92b7aa0aea79d3b675ac363cad01ba524c4e (diff)
downloadguix-patches-8e14e059c40c22b946e7beef64dc9e4d3b3d5e35.tar
guix-patches-8e14e059c40c22b946e7beef64dc9e4d3b3d5e35.tar.gz
gnu: Add idle3-tools.
* gnu/packages/disk.scm (idle3-tools): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index b9240a392a..11454d85f8 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -171,3 +171,35 @@ transport), SCSI and ATAPI tape drives, and SCSI enclosures. This utility can
also send commands associated with starting and stopping the media, loading
and unloading removable media and some other housekeeping functions.")
(license bsd-3)))
+
+(define-public idle3-tools
+ (package
+ (name "idle3-tools")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/idle3-tools/idle3-tools-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "00ia7xq9yldxyl9gz0mr4xa568nav14p0fnv82f2rbbkg060cy4p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags (list "CC=gcc"
+ (string-append "manprefix=")
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out")))))
+ (home-page "http://idle3-tools.sourceforge.net")
+ (synopsis "Change or disable Western Digital hard drives' Idle3 timer")
+ (description
+ "Idle3-tools provides a utility to get, set, or disable the Idle3 timer
+present in many Western Digital hard drives. This timer is part of the
+\"IntelliPark\" feature that stops the disk when not in use. Unfortunately,
+the default timer setting is not well suited to Linux or other *nix systems,
+and can dramatically shorten the lifespan of the drive if left unchecked.")
+ (license gpl3+)))