summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/disk.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm176
1 files changed, 74 insertions, 102 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index a9880d7abb..d74d941ee0 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -141,7 +141,7 @@
"/share/man/man8"))
#t))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
`(("util-linux:lib" ,util-linux "lib"))) ; libblkid
(home-page "https://bcache.evilpiepirate.org")
@@ -209,15 +209,14 @@ and write-back caching.")
(("`which udevil 2>/dev/null`") "/run/setuid-programs/udevil"))
#t)))))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(inputs
- `(("cifs-utils" ,cifs-utils)
- ("curlftpfs" ,curlftpfs)
- ("eudev" ,eudev)
- ("fakeroot" ,fakeroot)
- ("glib" ,glib)
- ("sshfs" ,sshfs)))
+ (list cifs-utils
+ curlftpfs
+ eudev
+ fakeroot
+ glib
+ sshfs))
(synopsis "Device and file system manager")
(description "udevil is a command line program that mounts and unmounts
removable devices without a password, shows device info, and monitors device
@@ -249,9 +248,8 @@ tmpfs/ramfs filesystems.")
(("/usr/bin/python") (which "python")))
#t)))))
(inputs
- `(("lvm2" ,lvm2)
- ("readline" ,readline)
- ("util-linux" ,util-linux "lib")))
+ (list lvm2 readline
+ `(,util-linux "lib")))
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -335,8 +333,7 @@ tables, and it understands a variety of different formats.")
(substitute* "autogen.sh"
(("\\./configure") "")))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
+ (list autoconf automake))
(home-page "https://github.com/baruch/gpart")
(synopsis "Guess and recover PC-style partition tables")
(description
@@ -424,7 +421,7 @@ scheme.")
`(#:configure-flags (list (string-append "CXX=" ,(cxx-for-target)))))
(home-page "https://www.gnu.org/software/ddrescue/ddrescue.html")
(synopsis "Data recovery utility")
- (native-inputs `(("lzip" ,lzip)))
+ (native-inputs (list lzip))
(description
"GNU ddrescue is a fully automated data recovery tool. It copies data
from one file to another, working to rescue data in case of read errors. The
@@ -451,10 +448,9 @@ to recover data more efficiently by only reading the necessary blocks.")
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "CC=" ,(cc-for-target)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ;; For tests.
- ("xxd" ,xxd)))
+ (list autoconf automake
+ ;; For tests.
+ xxd))
(home-page "https://github.com/dosfstools/dosfstools")
(synopsis "Utilities for making and checking MS-DOS FAT file systems")
(description
@@ -489,7 +485,7 @@ which respectively make and check MS-DOS FAT file systems.")
;; Add fsck.vfat symlink to match the Linux driver name.
(symlink exe "fsck.vfat")
#t)))))
- (inputs `(("dosfstools" ,dosfstools/static)))
+ (inputs (list dosfstools/static))
(home-page (package-home-page dosfstools))
(synopsis "Statically linked fsck.fat from dosfstools")
(description "This package provides a statically-linked @command{fsck.fat}
@@ -570,17 +566,13 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
;; as '/dev/disk/by-id'
`(#:tests? #f))
(inputs
- `(("util-linux" ,util-linux "lib")
- ("parted" ,parted)
- ("glib" ,glib)
- ("gtkmm" ,gtkmm-3)
- ("libxml2" ,libxml2)))
+ (list `(,util-linux "lib") parted glib gtkmm-3 libxml2))
(native-inputs
- `(("intltool" ,intltool)
- ("itstool" ,itstool)
- ("lvm2" ,lvm2) ; for tests
- ("yelp-tools" ,yelp-tools)
- ("pkg-config" ,pkg-config)))
+ (list intltool
+ itstool
+ lvm2 ; for tests
+ yelp-tools
+ pkg-config))
(home-page "https://gparted.org/")
(synopsis "Partition editor to graphically manage disk partitions")
(description "GParted is a GNOME partition editor for creating,
@@ -638,8 +630,7 @@ systems. Output format is completely customizable.")
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "install-extra" make-flags))))))
(inputs
- `(("eudev" ,eudev)
- ("parted" ,parted)))
+ (list eudev parted))
(home-page "http://oss.digirati.com.br/f3/")
(synopsis "Test real capacity of flash memory cards and such.")
(description "F3 (Fight Flash Fraud or Fight Fake Flash) tests the full
@@ -675,12 +666,11 @@ a card with a smaller capacity than stated.")
(invoke "python" "-m" "unittest" "discover" "-v")
#t)))))
(native-inputs
- `(("e2fsprogs" ,e2fsprogs)
- ("pkg-config" ,pkg-config)))
+ (list e2fsprogs pkg-config))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(inputs
- `(("parted" ,parted)))
+ (list parted))
(home-page "https://github.com/dcantrell/pyparted")
(synopsis "Parted bindings for Python")
(description "This package provides @code{parted} bindings for Python.")
@@ -701,10 +691,9 @@ a card with a smaller capacity than stated.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("glib" ,glib)
- ("sqlite" ,sqlite)))
+ (list glib sqlite))
(arguments
`(#:tests? #f ; no test suite
#:phases
@@ -744,12 +733,11 @@ Duperemove can also take input from the @command{fdupes} program.")
"0lfjrpv3z4h0knd3v94fijrw2zjba51mrp3mjqx2c98wr428l26f"))))
(build-system python-build-system)
(inputs
- `(("w3m" ,w3m)))
+ (list w3m))
(native-inputs
- `(("which" ,which)
-
- ;; For tests.
- ("python-pytest" ,python-pytest)))
+ (list which
+ ;; For tests.
+ python-pytest))
(arguments
'( ;; The 'test' target runs developer tools like pylint, which fail.
#:test-target "test_pytest"
@@ -791,9 +779,7 @@ automatically finding out which program to use for what file type.")
"16rhfz6sjwxlmss1plb2wv2i3jq6wza02rmz1d2jrlnsq67p98vc"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("swig" ,swig)
- ("python" ,python-3))) ; used to generate the Python bindings
+ (list pkg-config swig python-3)) ; used to generate the Python bindings
(inputs
`(("cryptsetup" ,cryptsetup)
("nss" ,nss)
@@ -834,23 +820,20 @@ passphrases.")
"1vi61bm9wyawklswh9mj9zdp28ar7r97qckwnhgiyila73fb3jx2"))))
(build-system gnu-build-system)
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("automake" ,automake)
- ("autoconf" ,autoconf)
- ("bash-completion" ,bash-completion)
- ("docbook-xsl" ,docbook-xsl)
- ("libtool" ,libtool)
- ("libxml2" ,libxml2)
- ("pkg-config" ,pkg-config)
- ("xmlto" ,xmlto)
- ;; Required for offline docbook generation.
- ("which" ,which)))
+ (list asciidoc
+ automake
+ autoconf
+ bash-completion
+ docbook-xsl
+ libtool
+ libxml2
+ pkg-config
+ xmlto
+ ;; Required for offline docbook generation.
+ which))
(inputs
- `(("eudev" ,eudev)
- ("json-c" ,json-c)
- ("keyutils" ,keyutils)
- ("kmod" ,kmod)
- ("util-linux" ,util-linux "lib")))
+ (list eudev json-c keyutils kmod
+ `(,util-linux "lib")))
(arguments
`(#:configure-flags
(list "--disable-asciidoctor" ; use docbook-xsl instead
@@ -890,8 +873,8 @@ libnvdimm (non-volatile memory device) sub-system in the Linux kernel.")
(base32
"1n7vsqvh7y6yvil682q129d21yhb0cmvd5fvsbkza7ypd78inhlk"))))
(build-system gnu-build-system)
- (inputs `(("lvm2" ,lvm2)))
- (native-inputs `(("which" ,which)))
+ (inputs (list lvm2))
+ (native-inputs (list which))
(arguments
`(#:tests? #f ; No tests.
;; Prevent a race condition where some target would attempt to link
@@ -947,22 +930,22 @@ to create devices with respective mappings for the ATARAID sets discovered.")
("python" ,python-wrapper)
("util-linux" ,util-linux)))
(inputs
- `(("btrfs-progs" ,btrfs-progs)
- ("cryptsetup" ,cryptsetup)
- ("dosfstools" ,dosfstools)
- ("dmraid" ,dmraid)
- ("eudev" ,eudev)
- ("glib" ,glib)
- ("kmod" ,kmod)
- ("libbytesize" ,libbytesize)
- ("libyaml" ,libyaml)
- ("lvm2" ,lvm2)
- ("mdadm" ,mdadm)
- ("ndctl" ,ndctl)
- ("nss" ,nss)
- ("parted" ,parted)
- ("volume-key" ,volume-key)
- ("xfsprogs" ,xfsprogs)))
+ (list btrfs-progs
+ cryptsetup
+ dosfstools
+ dmraid
+ eudev
+ glib
+ kmod
+ libbytesize
+ libyaml
+ lvm2
+ mdadm
+ ndctl
+ nss
+ parted
+ volume-key
+ xfsprogs))
(home-page "https://github.com/storaged-project/libblockdev")
(synopsis "Library for manipulating block devices")
(description
@@ -1125,8 +1108,7 @@ since they are better handled by external tools.")
(("~/.config/xfe") xfe)))
#t))))))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(inputs
`(("bash" ,bash)
("coreutils" ,coreutils)
@@ -1204,15 +1186,12 @@ that support this feature).")
"0w5hws12l167mbr4n6a6fl0mhf8mci61fsn55lh2cxz33f7q8n2x"))))
(build-system gnu-build-system)
(inputs
- `(;; memkind patched jemalloc to add je_arenalookupx,
- ;; je_check_reallocatex--i.e. they forked jemalloc.
- ;("jemalloc" ,jemalloc)
- ("ndctl" ,ndctl)
- ("numactl" ,numactl)))
+ (list ;; memkind patched jemalloc to add je_arenalookupx,
+ ;; je_check_reallocatex--i.e. they forked jemalloc.
+ ;("jemalloc" ,jemalloc)
+ ndctl numactl))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(arguments
`(#:configure-flags
(list (string-append "--docdir=" (assoc-ref %outputs "out")
@@ -1296,10 +1275,9 @@ inspecting MMC storage devices from userspace.")
(invoke "nosetests" "-v"
"--exclude" "test_bmap_helpers"))))))
(native-inputs
- `(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)))
+ (list python-mock python-nose))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(home-page "https://github.com/intel/bmap-tools")
(synopsis "Create block map for a file or copy a file using block map")
(description "Bmaptool is a tool for creating the block map (bmap) for a
@@ -1340,15 +1318,9 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(doc (string-append out "/share/doc/" ,name "-" ,version)))
(copy-recursively "examples" (string-append doc "/examples"))))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(inputs
- `(("cairo" ,cairo)
- ("pango" ,pango)
- ("tokyocabinet" ,tokyocabinet)
- ("ncurses" ,ncurses)))
+ (list cairo pango tokyocabinet ncurses))
(home-page "http://duc.zevv.nl")
(synopsis "Library and suite of tools for inspecting disk usage")
(description "Duc maintains a database of accumulated sizes of