summaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-28 22:54:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:19 +0200
commit5e6fd87acf58d10199751276bfe8f890c8d01b3e (patch)
treeb476c01c17aa186b7c1d936ae5ab63d486b1076c /gnu/packages/digest.scm
parent1bf1bda93c969c71612ab5b86fe93d0e3d63d534 (diff)
downloadguix-patches-5e6fd87acf58d10199751276bfe8f890c8d01b3e.tar
guix-patches-5e6fd87acf58d10199751276bfe8f890c8d01b3e.tar.gz
gnu: xxhash: Update to 0.6.5.
* gnu/packages/digest.scm (xxhash): Update to 0.6.5. [arguments]: Disable #:parallel-tests?.
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index dccba2a07c..d5533bc474 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -25,7 +25,7 @@
(define-public xxhash
(package
(name "xxhash")
- (version "0.6.4")
+ (version "0.6.5")
(source
(origin
(method git-fetch)
@@ -33,7 +33,7 @@
(url "https://github.com/Cyan4973/xxHash")
(commit (string-append "v" version))))
(sha256
- (base32 "1az5vm14rdc3pa3l0wj180wpii14if16diril3gz8q9ip1215gwj"))))
+ (base32 "137hifc3f3cb4ib64rd6y83arc9hmbyncgrij2v8m94mx66g2aks"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -41,6 +41,8 @@
"XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
(string-append "prefix=" (assoc-ref %outputs "out")))
#:test-target "test"
+ ;; Parallel testing tries to run ‘xxhsum’ before it's been built.
+ #:parallel-tests? #f
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script