summaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-23 03:57:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-23 19:45:57 +0100
commit491b91dc8a879e092c451ac15a9842f2feb40be4 (patch)
treeb6653265237b675bdd10d70eb3298d1a5ee98df0 /gnu/packages/digest.scm
parent8cd2341028c3f3742f2539efa0f354d8ad419558 (diff)
downloadguix-patches-491b91dc8a879e092c451ac15a9842f2feb40be4.tar
guix-patches-491b91dc8a879e092c451ac15a9842f2feb40be4.tar.gz
gnu: xxhash: Update to 0.7.2.
* gnu/packages/digest.scm (xxhash): Update to 0.7.2. [arguments]: Run ‘make check’ in parallel.
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 7ec4ca1495..f76cbabcf8 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,7 +25,7 @@
(define-public xxhash
(package
(name "xxhash")
- (version "0.6.5")
+ (version "0.7.2")
(source
(origin
(method git-fetch)
@@ -34,16 +34,13 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "137hifc3f3cb4ib64rd6y83arc9hmbyncgrij2v8m94mx66g2aks"))))
+ (base32 "1f9gl0cymmi92ihsfan0p4zmyf2hxwx4arjimpbmbp719nbcvdsx"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
(list "CC=gcc"
"XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
(string-append "prefix=" (assoc-ref %outputs "out")))
- #:test-target "test"
- ;; Parallel testing tries to run ‘xxhsum’ before it's been built.
- #:parallel-tests? #f
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script