summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-02-11 18:57:38 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-02-11 18:57:38 -0800
commitf813750a4aa07797e0120babdd5efbe17f1d3911 (patch)
treec44b8acbb4d124f98d87f41decd259c4560cc27a /gnu/packages/diffoscope.scm
parent6bf136c890ba001604e4f404410c7d9feee8dcb1 (diff)
downloadguix-patches-f813750a4aa07797e0120babdd5efbe17f1d3911.tar
guix-patches-f813750a4aa07797e0120babdd5efbe17f1d3911.tar.gz
gnu: diffoscope: Update to 166.
* gnu/packages/diffoscope.scm (diffoscope): Update to 166. [source]: Add patch to use magic.open compatibility interface. * gnu/packages/patches/diffoscope-revert-to-magic-open.patch: New file. * gnu/local.mk [dist_patch_DATA]: New patch.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 7108c773ae..a31ac485c2 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -72,7 +72,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "165")
+ (version "166")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -81,7 +81,9 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0chi8drkxdwk7mlfgljij0nihnxp9pi5ybhqaq8rc4l1zl6srirb"))))
+ "0vc4a38ii6b10af4c7cxfkvj4lk4ihx1xs4q5lshnkyg74gmm21b"))
+ (patches (search-patches
+ "diffoscope-revert-to-magic-open.patch"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases