summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-06-19 19:49:16 +0000
committerVagrant Cascadian <vagrant@debian.org>2020-06-19 14:06:29 -0700
commitd72009bf0841b55e460bcc049e3723c3bd4f6603 (patch)
tree582a30a821da763037755db2bbbb80e9450b6a5a /gnu/packages/diffoscope.scm
parent748a167c81521e7e2fc57c2e51f48e4d90e4448b (diff)
downloadguix-patches-d72009bf0841b55e460bcc049e3723c3bd4f6603.tar
guix-patches-d72009bf0841b55e460bcc049e3723c3bd4f6603.tar.gz
gnu: diffoscope: Update to 148.
* gnu/packages/diffoscope (diffoscope): Update to 148. [arguments] Remove add-known-tools phase, fixed upstream.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 51a1127783..f5387f8501 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -72,7 +72,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "147")
+ (version "148")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -81,7 +81,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0vfj9zv9mh9fffnm3h721yfkrkksv6667x6xjihvmfs8j9javgaz"))))
+ "0siv5z8iqgkzl51dmv69ifqids6hqmiir00yyl1aaqbginrwyhyv"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -92,12 +92,6 @@
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
- ;; Patch in support for known tools
- (add-after 'unpack 'add-known-tools
- (lambda _
- (substitute* "diffoscope/external_tools.py"
- (("'debian': 'openssl'")
- "'debian': 'openssl', 'guix': 'openssl'"))))
;; This test is broken because our `file` package has a
;; bug in berkeley-db file type detection.
(add-after 'unpack 'remove-berkeley-test