summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 20:16:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-19 00:48:40 +0100
commitb3a0db7a0e5fa7186c090647cfd5666e2b9287ff (patch)
tree83bd05ee950bb3d2ecd3893e4d66a20cd38c9c2e /gnu/packages/diffoscope.scm
parent62085c36fa8b8b7f49b1fa81f73074195dc812ab (diff)
downloadguix-patches-b3a0db7a0e5fa7186c090647cfd5666e2b9287ff.tar
guix-patches-b3a0db7a0e5fa7186c090647cfd5666e2b9287ff.tar.gz
gnu: diffoscope: Remove input labels.
* gnu/packages/diffoscope.scm (diffoscope)[native-inputs]: Remove input labels.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm143
1 files changed, 73 insertions, 70 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index ff4b38c6bc..3c57b5a8c4 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -149,78 +149,81 @@
acl ;for getfacl
colordiff
xxd))
- (native-inputs `(("help2man" ,help2man)
- ;; Below are modules used for tests.
- ("binwalk" ,binwalk)
- ("python-pytest" ,python-pytest)
- ("python-chardet" ,python-chardet)
- ("python-black" ,python-black)
- ("python-h5py" ,python-h5py)
- ("python-pypdf2" ,python-pypdf2)
- ("python-progressbar33" ,python-progressbar33)
- ;; The test suite skips tests when these are missing.
- ,@(match (%current-system)
- ;; ghc is only available on x86 currently.
- ((or "x86_64-linux" "i686-linux")
- `(("ghc" ,ghc)))
- (_
- `()))
- ,@(match (%current-system)
- ;; openjdk and dependent packages are only
- ;; available on x86_64 currently.
- ((or "x86_64-linux")
- `(("enjarify" ,enjarify)
- ;; no unversioned openjdk available
- ("openjdk:jdk" ,openjdk12 "jdk")))
- (_
- `()))
- ("abootimg" ,abootimg)
- ("bdb" ,bdb)
- ("binutils" ,binutils)
- ("bzip2" ,bzip2)
- ("cdrtools" ,cdrtools)
- ("colord" ,colord)
- ("cpio" ,cpio)
- ("docx2txt" ,docx2txt)
- ("dtc" ,dtc)
- ("e2fsprogs" ,e2fsprogs)
- ("ffmpeg" ,ffmpeg)
+ (native-inputs
+ (append
+ (list help2man
+
+ ;; Below are packages used for tests.
+ binwalk
+ python-pytest
+ python-chardet
+ python-black
+ python-h5py
+ python-pypdf2
+ python-progressbar33
+
+ abootimg
+ bdb
+ binutils
+ bzip2
+ cdrtools
+ colord
+ cpio
+ docx2txt
+ dtc
+ e2fsprogs
+ ffmpeg
+
+ ;; XXX: Must be the same version as python-magic uses;
+ ;; remove when 'file' is updated.
+ file-next
- ;; XXX: Must be the same version as python-magic uses;
- ;; remove when 'file' is updated.
- ("file" ,file-next)
+ fpc
+ gettext-minimal
+ ghostscript
+ `(,giflib "bin")
+ gnumeric
+ gnupg
+ hdf5
+ imagemagick
+ libarchive
+ llvm
+ lz4
+ mono
+ ocaml
+ odt2txt
+ openssh
+ openssl
+ pgpdump
+ poppler
+ python-jsbeautifier
+ r-minimal
+ rpm
+ sng
+ sqlite
+ squashfs-tools
+ tcpdump
+ unzip
+ wabt
+ xxd
+ xz
+ zip
+ zstd)
- ("fpc" ,fpc)
- ("gettext" ,gettext-minimal)
- ("ghostscript" ,ghostscript)
- ("giflib:bin" ,giflib "bin")
- ("gnumeric" ,gnumeric)
- ("gnupg" ,gnupg)
- ("hdf5" ,hdf5)
- ("imagemagick" ,imagemagick)
- ("libarchive" ,libarchive)
- ("llvm" ,llvm)
- ("lz4" ,lz4)
- ("mono" ,mono)
- ("ocaml" ,ocaml)
- ("odt2txt" ,odt2txt)
- ("openssh" ,openssh)
- ("openssl" ,openssl)
- ("pgpdump" ,pgpdump)
- ("poppler" ,poppler)
- ("python-jsbeautifier" ,python-jsbeautifier)
- ("r-minimal" ,r-minimal)
- ("rpm" ,rpm)
- ("sng" ,sng)
- ("sqlite" ,sqlite)
- ("squashfs-tools" ,squashfs-tools)
- ("tcpdump" ,tcpdump)
- ("unzip" ,unzip)
- ("wabt" ,wabt)
- ("xxd" ,xxd)
- ("xz" ,xz)
- ("zip" ,zip)
- ("zstd" ,zstd)))
+ ;; Also for tests. The test suite skips tests when these are missing.
+ (match (%current-system)
+ ;; ghc is only available on x86 currently.
+ ((or "x86_64-linux" "i686-linux")
+ (list ghc))
+ (_ '()))
+ (match (%current-system)
+ ;; openjdk and dependent packages are only
+ ;; available on x86_64 currently.
+ ((or "x86_64-linux")
+ (list enjarify)
+ ;; No unversioned openjdk available.
+ (list `(,openjdk12 "jdk")))
+ (_ '()))))
(home-page "https://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description