summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/diffoscope.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f0197817a6..696270d506 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -140,14 +140,14 @@
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man/man1")))
(install-file "doc/diffoscope.1" man)))))))
- (inputs `(("rpm" ,rpm) ;for rpm-python
- ("python-debian" ,python-debian)
- ("python-libarchive-c" ,python-libarchive-c)
- ("python-magic" ,python-magic)
- ("python-tlsh" ,python-tlsh)
- ("acl" ,acl) ;for getfacl
- ("colordiff" ,colordiff)
- ("xxd" ,xxd)))
+ (inputs (list rpm ;for rpm-python
+ python-debian
+ python-libarchive-c
+ python-magic
+ python-tlsh
+ acl ;for getfacl
+ colordiff
+ xxd))
(native-inputs `(("help2man" ,help2man)
;; Below are modules used for tests.
("binwalk" ,binwalk)
@@ -243,10 +243,7 @@ install.")
(base32
"19lwsxq53isgfkvlxvxqqmbjfcim3lhcxwk7m9ddfjiynhq74949"))))
(inputs
- `(("python-debian" ,python-debian)
- ("python-distro" ,python-distro)
- ("python-libarchive-c" ,python-libarchive-c)
- ("python-rstr" ,python-rstr)))
+ (list python-debian python-distro python-libarchive-c python-rstr))
(native-inputs
`(("diffoscope" ,diffoscope)
("help2man" ,help2man)
@@ -324,10 +321,9 @@ them in detail for later analysis.")
(string-append share "/doc/" ,name "-" ,version)))
#t)))))
(propagated-inputs
- `(("python-requests" ,python-requests)))
+ (list python-requests))
(native-inputs
- `(("gzip" ,gzip)
- ("python-docutils" ,python-docutils)))
+ (list gzip python-docutils))
(build-system python-build-system)
(home-page "https://try.diffoscope.org")
(synopsis "Client for remote diffoscope service")