summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-10-29 12:31:01 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-10-29 13:19:11 -0700
commit52ab88a5aae15f031ba5046a2997b04aabbf188a (patch)
tree11a7ae5acddce572b64eb65c484b92f43e7ff528 /gnu/packages/diffoscope.scm
parentcbe902545d6911b254e6c29a7b3a0792b184fefb (diff)
downloadguix-patches-52ab88a5aae15f031ba5046a2997b04aabbf188a.tar
guix-patches-52ab88a5aae15f031ba5046a2997b04aabbf188a.tar.gz
gnu: diffoscope: Update to 189.
* gnu/packages/diffoscope.scm (diffoscope): Update to 189. [arguments] Remove phases 'use-dumppdf-py and 'fpc-external-tool. Update 'skip-python-tests.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm29
1 files changed, 3 insertions, 26 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index cb4c766f4e..dfb2e05f16 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -73,7 +73,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "188")
+ (version "189")
(source
(origin
(method git-fetch)
@@ -82,7 +82,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1byd28ihni5g0ikjjcsq68smj1rw33vv9z0cymqa4ds670c77yvn"))
+ (base32 "0dai9gwsr9xnficjy8myq6xr301y4iy82aidm936qsqjwrp8q1sm"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -115,30 +115,7 @@
;; phase when python is upgraded
(substitute* "tests/comparators/test_python.py"
(("def test_identification")
- "def skip_test_identification"))
- (substitute* "tests/comparators/test_python.py"
- (("def test_diff")
- "def skip_test_diff"))))
- (add-after 'unpack 'use-dumppdf-py
- ;; python-pdfminer-six ships "dumppdf" as "dumppdf.py"
- ;; https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/283
- ;; Fixed upstream, remove this phase when updating to
- ;; diffoscope 189
- (lambda _
- (substitute* "diffoscope/comparators/pdf.py"
- (("dumppdf") "dumppdf.py"))
- (substitute* "diffoscope/external_tools.py"
- (("dumppdf") "dumppdf.py"))
- (substitute* "diffoscope/external_tools.py"
- (("'debian': 'python3-pdfminer'")
- "'debian': 'python3-pdfminer', 'guix': 'python-pdfminer-six'"))))
- (add-after 'unpack 'fpc-external-tool
- ;; Fixed upstream, remove this phase when updating to
- ;; diffoscope 189
- (lambda _
- (substitute* "diffoscope/external_tools.py"
- (("'debian': 'fp-utils'")
- "'debian': 'fp-utils', 'guix': 'fpc'"))))
+ "def skip_test_identification"))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))