summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-03-22 19:09:20 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-03-22 19:50:28 -0700
commit45dfcdba86ff5cf31bdf6e07d73b161f5d7fac42 (patch)
treeb97d3648d78dc3e8e7ffe8e280c0bfcc91b6dc47 /gnu/packages/diffoscope.scm
parentca5420d3b27dcefa9ada704db0d694ff62238b73 (diff)
downloadguix-patches-45dfcdba86ff5cf31bdf6e07d73b161f5d7fac42.tar
guix-patches-45dfcdba86ff5cf31bdf6e07d73b161f5d7fac42.tar.gz
gnu: diffoscope: Update to 170.
* gnu/packages/diffoscope.scm (diffoscope): Update to 170. [arguments]: Remove skip-dex-test-with-missing-procyon phase.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index a2490330e0..20ba92709a 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -72,7 +72,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "168")
+ (version "170")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -81,7 +81,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "18rs4jfx50d7vkaqcc46r7pccgizp0is56267sq13vbfvz758dhh"))))
+ "0s1z4yc5d10ns4x28d2lm8py30r7sq4764q6b8yxcwxwfrjibmb0"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -121,13 +121,6 @@
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")
#t))
- (add-before 'check 'skip-dex-test-with-missing-procyon
- (lambda _
- ;; This test actually requires procyon decompiler
- (substitute* "tests/comparators/test_dex.py"
- (("skip_unless_tools_exist.\"enjarify\", \"zipinfo\", \"javap\"")
- "skip_unless_tools_exist(\"enjarify\", \"zipinfo\", \"javap\", \"procyon\""))
- #t))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))