summaryrefslogtreecommitdiff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-10 00:42:22 -0400
committerMark H Weaver <mhw@netris.org>2018-04-10 00:42:22 -0400
commitf89aa1521af69b0e1a1350c2380579788b0f8945 (patch)
tree5009cca687ac669ef846920877cbfb6fffdd9893 /gnu/packages/dictionaries.scm
parent169c658f7f286efae397fa3eda55b1c56fa92a01 (diff)
parent60e1de6d95bd32b4996c199708541781b8f828fd (diff)
downloadguix-patches-f89aa1521af69b0e1a1350c2380579788b0f8945.tar
guix-patches-f89aa1521af69b0e1a1350c2380579788b0f8945.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 4334203f7b..d09280a3d4 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -211,7 +211,7 @@ It comes with a German-English dictionary with approximately 270,000 entries.")
(define-public grammalecte
(package
(name "grammalecte")
- (version "0.6.2")
+ (version "0.6.3.1")
(source
(origin
(method url-fetch/zipbomb)
@@ -219,8 +219,21 @@ It comes with a German-English dictionary with approximately 270,000 entries.")
"Grammalecte-fr-v" version ".zip"))
(sha256
(base32
- "0pvblclvbxbfgmq0cvmpmzpf6bi6r41arndwprl7ab9kci9hi8j2"))))
+ "0jlzrhpx9qvjdq679w188p86x09yfjf3l0h4scjl9w26yyp53gr8"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-setup
+ ;; Fix typos in "setup.py". In particular, add the new
+ ;; "graphspell" module introduced in 0.6.2. Reported upstream:
+ ;; <https://www.dicollecte.org/thread.php?prj=fr&t=709>
+ (lambda _
+ (substitute* "setup.py"
+ (("packages=\\['grammalecte', 'grammalecte.fr'\\],")
+ "packages=['grammalecte', 'grammalecte.fr', 'grammalecte.graphspell'],")
+ (("_dictionaries/French.bdic") "graphspell/_dictionaries/fr.bdic"))
+ #t)))))
(home-page "https://www.dicollecte.org")
(synopsis "French spelling and grammar checker")
(description "Grammalecte is a grammar checker dedicated to the French