summaryrefslogtreecommitdiff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-25 11:40:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-26 22:47:16 +0300
commit196c8b3739d16241da73c78536ce86aaab948677 (patch)
treeeb9c062f8c2e085e138f1a35c3dc57408560d5fe /gnu/packages/dictionaries.scm
parente5e5eb1fcf4c0aab10e2d6ed7fa34257a3c87e58 (diff)
downloadguix-patches-196c8b3739d16241da73c78536ce86aaab948677.tar
guix-patches-196c8b3739d16241da73c78536ce86aaab948677.tar.gz
gnu: translate-shell: Update to 0.9.6.7.
* gnu/packages/patches/translate-shell-fix-curl-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/dictionaries.scm (translate-shell): Update to 0.9.6.7. [source](patches): Add it. [home-page]: Append slash.
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 3f50070ef7..85979ba096 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -27,6 +27,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages curl)
#:use-module (gnu packages emacs)
@@ -239,7 +240,7 @@ and a Python library.")
(define-public translate-shell
(package
(name "translate-shell")
- (version "0.9.6.4")
+ (version "0.9.6.7")
(source
(origin
(method url-fetch)
@@ -247,7 +248,8 @@ and a Python library.")
version ".tar.gz"))
(sha256
(base32
- "1fg6nf1plvgimc57fsdr9rcjbf7jvmk5jrlj5ya509vpdcdgvj2s"))
+ "0inv6r3qbihn2ff1sgcly89r04k4vgcbvvyl50ln0mxlapbhpy95"))
+ (patches (search-patches "translate-shell-fix-curl-tests.patch"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(arguments
@@ -261,7 +263,8 @@ and a Python library.")
(emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
(install-file "google-translate-mode.el" dest)
(emacs-generate-autoloads ,name dest)))))
- #:make-flags (list (string-append "PREFIX=" %output))
+ #:make-flags (list (string-append "PREFIX=" %output)
+ "NETWORK_ACCESS=no test")
#:imported-modules (,@%gnu-build-system-modules (guix build emacs-utils))
#:modules ((guix build gnu-build-system)
(guix build emacs-utils)
@@ -274,7 +277,7 @@ and a Python library.")
(native-inputs
`(("emacs" ,emacs-minimal)
("util-linux" ,util-linux))) ; hexdump, for the test
- (home-page "https://www.soimort.org/translate-shell")
+ (home-page "https://www.soimort.org/translate-shell/")
(synopsis "Translations from the command line")
(description
"Translate Shell (formerly Google Translate CLI) is a command-line