summaryrefslogtreecommitdiff
path: root/gnu/packages/dhall.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/dhall.scm
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
downloadguix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar
guix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar.gz
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/dhall.scm')
-rw-r--r--gnu/packages/dhall.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/dhall.scm b/gnu/packages/dhall.scm
index c0776902e7..91c31ebc55 100644
--- a/gnu/packages/dhall.scm
+++ b/gnu/packages/dhall.scm
@@ -30,14 +30,14 @@
(define-public dhall
(package
(name "dhall")
- (version "1.32.0")
+ (version "1.39.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/dhall/dhall-"
version ".tar.gz"))
(sha256
- (base32 "1imj0bh5365pdizvjbw2wqz0g9hakigf1zm4fr6379qdchxpp90p"))))
+ (base32 "1by2d84fbckspczddl4npfsf89q6nprmbg0i5g8yr1psp0fpl4ab"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
@@ -58,14 +58,16 @@
("ghc-lens-family-core" ,ghc-lens-family-core)
("ghc-megaparsec" ,ghc-megaparsec)
("ghc-memory" ,ghc-memory)
+ ("ghc-mmorph" ,ghc-mmorph)
("ghc-network-uri" ,ghc-network-uri)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-parsers" ,ghc-parsers)
("ghc-parser-combinators" ,ghc-parser-combinators)
- ("ghc-prettyprinter" ,ghc-prettyprinter-1.6)
+ ("ghc-prettyprinter" ,ghc-prettyprinter)
("ghc-prettyprinter-ansi-terminal" ,ghc-prettyprinter-ansi-terminal)
("ghc-pretty-simple" ,ghc-pretty-simple)
("ghc-profunctors" ,ghc-profunctors)
+ ("ghc-pretty-simple" ,ghc-pretty-simple)
("ghc-repline" ,ghc-repline-0.3)
("ghc-serialise" ,ghc-serialise)
("ghc-scientific" ,ghc-scientific)
@@ -91,6 +93,7 @@
("ghc-tasty-expected-failure" ,ghc-tasty-expected-failure)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-silver" ,ghc-tasty-silver)
("ghc-turtle" ,ghc-turtle)
("ghc-mockery" ,ghc-mockery)
("ghc-doctest" ,ghc-doctest)))
@@ -102,8 +105,7 @@
(with-directory-excursion "dhall-lang/tests"
(for-each
delete-file
- '("import/failure/referentiallyInsane.dhall"
- "import/success/customHeadersA.dhall"
+ '("import/success/customHeadersA.dhall"
"import/success/noHeaderForwardingA.dhall"
"import/success/unit/RemoteAsTextA.dhall"
"import/success/unit/SimpleRemoteA.dhall"