summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-09-26 10:47:40 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-25 14:32:59 +0200
commite4276fc4c1c9035971a7d72328e8bea8b165c9c0 (patch)
tree8fefb23aa2d1cb588785f363bbc3e34ff7c706f3 /gnu/packages/debug.scm
parent1ea032fb5fc8dd6f7a10e5bc705e526d25fbe1b4 (diff)
downloadguix-patches-e4276fc4c1c9035971a7d72328e8bea8b165c9c0.tar
guix-patches-e4276fc4c1c9035971a7d72328e8bea8b165c9c0.tar.gz
gnu: mspdebug: Update to 0.25-0.4c4d94e.
* gnu/packages/debug.scm (mspdebug): Update to 0.25-0.4c4d94e. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm61
1 files changed, 32 insertions, 29 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 7363d45c43..c95cd036e8 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -757,35 +757,38 @@ use than similar tools like @command{mtrace}.")
(license license:gpl2+)))
(define-public mspdebug
- (package
- (name "mspdebug")
- (version "0.25")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dlbeer/mspdebug")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- "INSTALL=install"
- (string-append "PREFIX=" %output))))
- (inputs
- `(("libusb-compat" ,libusb-compat)
- ("readline" ,readline)))
- (synopsis "Debugging tool for MSP430 MCUs")
- (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+ ;; Last official release was 24 July 2017
+ (let ((commit "4c4d94e43bc4a18ecf82070ff81cd38dd5641e3b")
+ (revision "0"))
+ (package
+ (name "mspdebug")
+ (version (git-version "0.25" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlbeer/mspdebug")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lgw1dsc1aglyja610ichadvgs5b0df3wlarinczb0ykf431gjln"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ "INSTALL=install"
+ (string-append "PREFIX=" %output))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)
+ ("readline" ,readline)))
+ (synopsis "Debugging tool for MSP430 MCUs")
+ (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
MSP430-JTAG-TINY programmers, as well as many other compatible
devices. It can be used as a proxy for gdb or as an independent
debugger with support for programming, disassembly and reverse
engineering.")
- (home-page "https://github.com/dlbeer/mspdebug")
- (license license:gpl2+)))
+ (home-page "https://github.com/dlbeer/mspdebug")
+ (license license:gpl2+))))