summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-20 11:35:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-20 11:37:01 +0300
commitc23c628ea7a6435460d12969af5a3ba0e8d82004 (patch)
tree049fefad8b6c35de2dbf09d317564fe038597534 /gnu/packages/debug.scm
parent95bf72eeb0b99d6b26c3515fa78a587207c6f779 (diff)
downloadguix-patches-c23c628ea7a6435460d12969af5a3ba0e8d82004.tar
guix-patches-c23c628ea7a6435460d12969af5a3ba0e8d82004.tar.gz
Revert "gnu: julia: Build with zlib."
This reverts commit 95bf72eeb0b99d6b26c3515fa78a587207c6f779.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 4237a15f0a..556a1051f1 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,6 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -85,16 +84,16 @@ program to exhibit a bug.")
(define-public c-reduce
(package
(name "c-reduce")
- (version "2.5.0")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (list
- (string-append "https://embed.cs.utah.edu/creduce/"
+ (string-append "http://embed.cs.utah.edu/creduce/"
"creduce-" version ".tar.gz")))
(sha256
(base32
- "1r23lhzq3dz8vi2dalxk5las8bf0av2w94hxxbs61pr73m77ik9d"))
+ "0r9lvnifjcnsrkrk8k4mha1kmmb93jya7alm523ck59y3173bpi0"))
(modules '((guix build utils)))
(snippet
'(substitute* "clang_delta/TransformationManager.cpp"
@@ -132,7 +131,7 @@ program to exhibit a bug.")
"file-which" "getopt-tabular"
"regex-common" "sys-cpu"))))))
%standard-phases)))
- (home-page "https://embed.cs.utah.edu/creduce")
+ (home-page "http://embed.cs.utah.edu/creduce")
(synopsis "Reducer for interesting code")
(description
"C-Reduce is a tool that takes a large C or C++ program that has a