summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-01 13:00:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 13:31:51 +0300
commitb82cc0b90e271ef1cd1bd91f3f1ae729918eccd0 (patch)
treead43177f1e7dae1df5023bfd12abede00e5e4796 /gnu/packages/debug.scm
parentbbd04a4cc832a6d40a128fe449efe88cf5fd7bc9 (diff)
downloadguix-patches-b82cc0b90e271ef1cd1bd91f3f1ae729918eccd0.tar
guix-patches-b82cc0b90e271ef1cd1bd91f3f1ae729918eccd0.tar.gz
gnu: qemu-for-american-fuzzy-lop: Fix build.
* gnu/packages/debug.scm (qemu-for-american-fuzzy-lop)[source]: Add patch. * gnu/packages/patches/qemu-glibc-2.30.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index b3a000e6e3..f67f32a7f8 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2020 Eric Bavier <bavier@posteo.net>
-;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
@@ -269,7 +269,8 @@ down the road.")
(base32
"17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))
(patches
- (search-patches "qemu-glibc-2.27.patch"))))
+ (search-patches "qemu-glibc-2.27.patch"
+ "qemu-glibc-2.30.patch"))))
(build-system gnu-build-system)
(arguments
`(;; Running tests in parallel can occasionally lead to failures, like: