summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-04-11 11:42:44 -0500
committerEric Bavier <bavier@member.fsf.org>2019-04-11 12:17:01 -0500
commita6de569ea224a2f482c4d13c5f62240d1b1543a0 (patch)
tree2c5dcc2f6ab40526d4e1bf94507369c9f372d19f /gnu/packages/debug.scm
parent544265acba89a41691c6be5b4af8e3c2237cd5c6 (diff)
downloadguix-patches-a6de569ea224a2f482c4d13c5f62240d1b1543a0.tar
guix-patches-a6de569ea224a2f482c4d13c5f62240d1b1543a0.tar.gz
gnu: creduce: Upgrade to 2.8.0.
* gnu/packages/debug.scm (creduce): Upgrade to 2.8.0. [inputs]: Use llvm-6 and clang-6. Remove perl-sys-cpu. [arguments]: Use custom 'check phase.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 49e40ee9cd..b035951e26 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
@@ -92,11 +92,10 @@ program to exhibit a bug.")
;; home-page pointing to a bsd-2 license.
(license bsd-3)))
-;; Newer versions depend on LLVM and Clang >= 4, which have yet to be packaged.
(define-public c-reduce
(package
(name "c-reduce")
- (version "2.6.0")
+ (version "2.8.0")
(source
(origin
(method url-fetch)
@@ -105,12 +104,12 @@ program to exhibit a bug.")
"creduce-" version ".tar.gz")))
(sha256
(base32
- "0pf5q0n8vkdcr1wrkxn2jzxv0xkrir13bwmqfw3jpbm3dh2c3b6d"))))
+ "1vqx73ymfscvlyig03972a5m7ar3gx2yv6m8c6h2mibz792j5xkp"))))
(build-system gnu-build-system)
(inputs
`(("astyle" ,astyle)
- ("llvm" ,llvm-3.9.1)
- ("clang" ,clang-3.9.1)
+ ("llvm" ,llvm-6)
+ ("clang" ,clang-6)
("flex" ,flex)
("indent" ,indent)
("perl" ,perl)
@@ -118,11 +117,16 @@ program to exhibit a bug.")
("file-which" ,perl-file-which)
("getopt-tabular" ,perl-getopt-tabular)
("regex-common" ,perl-regexp-common)
- ("sys-cpu" ,perl-sys-cpu)
("term-readkey" ,perl-term-readkey)))
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ ;; Running all tests can take a looong time, and tests 4 and 5
+ ;; require frama-c or kcc. So run just one for sanity.
+ (invoke "./run_tests" "1"))))
(add-after 'install 'set-load-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Tell creduce where to find the perl modules it needs.
@@ -137,7 +141,7 @@ program to exhibit a bug.")
,(package-version perl)))
'("term-readkey" "exporter-lite"
"file-which" "getopt-tabular"
- "regex-common" "sys-cpu")))))
+ "regex-common")))))
#t)))))
(home-page "https://embed.cs.utah.edu/creduce")
(synopsis "Reducer for interesting code")