summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-14 17:37:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-14 17:37:20 +0100
commit8c72ed923d77ee55989965bb02628043799b9548 (patch)
tree802e6eb910719a98fa09bf7c2bd884097f649adc /gnu/packages/debug.scm
parent189be331acfda1c242a9c85fca8d2a0356742f48 (diff)
parentaac6cbbfede0bbfafdbbeeb460f00a244333895d (diff)
downloadguix-patches-8c72ed923d77ee55989965bb02628043799b9548.tar
guix-patches-8c72ed923d77ee55989965bb02628043799b9548.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 777018bfb2..1f238637a4 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,8 +67,6 @@
(bin (string-append out "/bin"))
(doc (string-append out "/share/doc/delta-" ,version)))
(begin
- (mkdir-p bin)
- (mkdir-p doc)
(for-each (lambda (h)
(install-file h doc))
`("License.txt" ,@(find-files "www" ".*\\.html")))
@@ -75,7 +74,7 @@
(install-file b bin))
`("delta" "multidelta" "topformflat"))))
#t))
- (delete 'configure))))
+ (delete 'configure)))) ; no configure script
(home-page "http://delta.tigris.org/")
(synopsis "Heuristical file minimizer")
(description
@@ -87,10 +86,11 @@ program to exhibit a bug.")
;; home-page pointing to a bsd-2 license.
(license bsd-3)))
+;; Newer versions depend on LLVM and Clang >= 4, which have yet to be packaged.
(define-public c-reduce
(package
(name "c-reduce")
- (version "2.5.0")
+ (version "2.6.0")
(source
(origin
(method url-fetch)
@@ -99,12 +99,12 @@ program to exhibit a bug.")
"creduce-" version ".tar.gz")))
(sha256
(base32
- "1r23lhzq3dz8vi2dalxk5las8bf0av2w94hxxbs61pr73m77ik9d"))))
+ "0pf5q0n8vkdcr1wrkxn2jzxv0xkrir13bwmqfw3jpbm3dh2c3b6d"))))
(build-system gnu-build-system)
(inputs
`(("astyle" ,astyle)
- ("llvm" ,llvm)
- ("clang" ,clang)
+ ("llvm" ,llvm-3.9.1)
+ ("clang" ,clang-3.9.1)
("flex" ,flex)
("indent" ,indent)
("perl" ,perl)
@@ -133,7 +133,7 @@ program to exhibit a bug.")
"file-which" "getopt-tabular"
"regex-common" "sys-cpu")))))
#t)))))
- (home-page "http://embed.cs.utah.edu/creduce")
+ (home-page "https://embed.cs.utah.edu/creduce")
(synopsis "Reducer for interesting code")
(description
"C-Reduce is a tool that takes a large C or C++ program that has a