summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-02-22 22:14:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-02-22 22:15:21 +0200
commit5c213d1bee60a7e2667feda9b8a2997624e5f447 (patch)
tree55270cb916e28ea5c13fb1bca72ffe1d1e446f3a /gnu/packages/debug.scm
parentcfcc0f3c63077520c8083cac11dab0d16f258155 (diff)
downloadguix-patches-5c213d1bee60a7e2667feda9b8a2997624e5f447.tar
guix-patches-5c213d1bee60a7e2667feda9b8a2997624e5f447.tar.gz
gnu: american-fuzzy-lop: Change custom qemu input.
* gnu/packages/debug.scm (american-fuzzy-lop)[inputs]: Custom-qemu now inherits from private qemu-minimal-2.10. * gnu/packages/bootloaders.scm (qemu-minimal-2.10): Add note to move variable to gnu/packages/debug.scm when no longer needed in bootloaders.scm.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 09efcbdd6c..2354f0fbb9 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -169,7 +169,7 @@ tools that process C/C++ code.")
(inputs
`(("custom-qemu"
;; The afl-qemu tool builds qemu 2.10.0 with a few patches applied.
- ,(package (inherit qemu-minimal)
+ ,(package (inherit (@@ (gnu packages bootloaders) qemu-minimal-2.10))
(name "afl-qemu")
(inputs
`(("afl-src" ,source)