summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2022-01-07 21:52:09 -0600
committerEric Bavier <bavier@posteo.net>2022-01-07 21:53:26 -0600
commit1ea3f1d17a13fb4acf203ae0cb46a1806d5a7f54 (patch)
treec9324d19f1bed12d0413e9689d2ff01d88233923 /gnu/packages/debug.scm
parent8521adf935919d1dc07078751f77003405cf79cb (diff)
downloadguix-patches-1ea3f1d17a13fb4acf203ae0cb46a1806d5a7f54.tar
guix-patches-1ea3f1d17a13fb4acf203ae0cb46a1806d5a7f54.tar.gz
gnu: c-vise: Update to 2.4.0.
* gnu/packages/debug.scm (c-vise)[source]: Update to 2.4.0. [inputs]: Use list syntax. Add python-chardet.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index f56f70d0a1..3bf7f6a8e0 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2020, 2021 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2019-2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
@@ -179,7 +179,7 @@ tools that process C/C++ code.")
(define-public c-vise
(package
(name "c-vise")
- (version "2.3.0")
+ (version "2.4.0")
(source
(origin
(method git-fetch)
@@ -187,19 +187,14 @@ tools that process C/C++ code.")
(url "https://github.com/marxin/cvise")
(commit (string-append "v" version))))
(sha256
- (base32 "0f6m58rak87gvcvxxcgp1bzbsv1q618h0iipmv0dx9jv1bn0qv43"))
+ (base32 "1i2z5q2pcwh1gpdqc24x1a2q5vzwhblzzq021nzwf304di7m18vl"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
(list flex python-pytest python-pytest-flake8))
(inputs
- `(("bash" ,bash-minimal) ; For wrap-program
- ("clang" ,clang)
- ("llvm" ,llvm)
- ("python" ,python)
- ("python-pebble" ,python-pebble)
- ("python-psutil" ,python-psutil)
- ("unifdef" ,unifdef)))
+ (list bash-minimal clang llvm unifdef
+ python python-pebble python-psutil python-chardet))
(arguments
`(#:phases
(modify-phases %standard-phases