summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-17 15:55:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-17 16:03:56 +0200
commit1d552f636bfcca40cde5a7c0e32d7a039580d2b5 (patch)
tree8e93bd65b66c23ea85c60d1bd28dada156cd9878 /gnu/packages/debug.scm
parentef421791c500d869f399da66503cbfd8c003717c (diff)
downloadguix-patches-1d552f636bfcca40cde5a7c0e32d7a039580d2b5.tar
guix-patches-1d552f636bfcca40cde5a7c0e32d7a039580d2b5.tar.gz
gnu: c-reduce: Update to 2.10.0.
* gnu/packages/debug.scm (c-reduce): Update to 2.10.0. [inputs]: Use default clang & llvm versions (currently 8).
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index e199e859ff..82631deef6 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -95,7 +95,7 @@ program to exhibit a bug.")
(define-public c-reduce
(package
(name "c-reduce")
- (version "2.8.0")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
@@ -103,13 +103,12 @@ program to exhibit a bug.")
(string-append "http://embed.cs.utah.edu/creduce/"
"creduce-" version ".tar.gz")))
(sha256
- (base32
- "1vqx73ymfscvlyig03972a5m7ar3gx2yv6m8c6h2mibz792j5xkp"))))
+ (base32 "0qx0zq8jxzx2as2zf0740g7kvgq163ayn3041di4vwk77490y76v"))))
(build-system gnu-build-system)
(inputs
`(("astyle" ,astyle)
- ("llvm" ,llvm-6)
- ("clang" ,clang-6)
+ ("llvm" ,llvm)
+ ("clang" ,clang)
("flex" ,flex)
("indent" ,indent)
("perl" ,perl)