summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-08-08 21:46:19 -0500
committerEric Bavier <bavier@member.fsf.org>2017-08-09 01:56:53 -0500
commit05cca6ce90407f19619a097815c53e5bd90d7780 (patch)
treef47ca44737fc97d646682dead172c7036a2794a3 /gnu/packages/debug.scm
parentbd5b5ac0c5721d85c8031f85df8a02b245170018 (diff)
downloadguix-patches-05cca6ce90407f19619a097815c53e5bd90d7780.tar
guix-patches-05cca6ce90407f19619a097815c53e5bd90d7780.tar.gz
gnu: stress-make: Patch default shell.
* gnu/packages/debug.scm (stress-make)[arguments]: Add 'set-default-shell phase.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm36
1 files changed, 21 insertions, 15 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 34c1061418..bde06f35b9 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -287,20 +287,26 @@ down the road.")
;; not accept a directory name instead. To let the gnu-build-system's
;; patch-* phases work properly, we unpack the source first, then
;; repack before the configure phase.
- `(#:configure-flags '("--with-make-tar=./make.tar.xz")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-make
- (lambda* (#:key inputs #:allow-other-keys)
- (zero? (system* "tar" "xf" (assoc-ref inputs "make-source")))))
- (add-before 'configure 'repack-make
- (lambda _
- (zero? (system* "tar" "cJf" "./make.tar.xz"
- (string-append "make-"
- ,(package-version gnu-make))))))
- (add-before 'configure 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (let ((make-dir (string-append "make-" (package-version gnu-make))))
+ `(#:configure-flags '("--with-make-tar=./make.tar.xz")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-make
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "tar" "xf" (assoc-ref inputs "make-source")))))
+ (add-after 'unpack-make 'set-default-shell
+ (lambda _
+ ;; Taken mostly directly from (@ (gnu packages base) gnu-make)
+ (substitute* (string-append ,make-dir "/job.c")
+ (("default_shell = .*$")
+ (format #f "default_shell = \"~a\";\n"
+ (which "sh"))))))
+ (add-before 'configure 'repack-make
+ (lambda _
+ (zero? (system* "tar" "cJf" "./make.tar.xz" ,make-dir))))
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi"))))))))
(home-page "https://github.com/losalamos/stress-make")
(synopsis "Expose race conditions in Makefiles")
(description