summaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-06-02 11:34:33 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-06-05 09:54:49 -0700
commit90041e9c28e71ee9736b5e9942625460f7deacd2 (patch)
tree998cf55f979e870bbe122966b44aff18417d413e /gnu/packages/debian.scm
parent36273ebde20db42d864e315c954d84d2b4957070 (diff)
downloadguix-patches-90041e9c28e71ee9736b5e9942625460f7deacd2.tar
guix-patches-90041e9c28e71ee9736b5e9942625460f7deacd2.tar.gz
gnu: debootstrap: Workaround for PATH issues.
* gnu/packages/debian (debootstrap): [arguments]: Substitute PATH to include $PATH. [description]: Remove obsolete workaround from description.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 1b401bc946..f94f49c51b 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -154,6 +154,11 @@ contains the archive keys used for that.")
(("/usr") ubuntu))
(substitute* "debootstrap"
(("=/usr") (string-append "=" out)))
+ ;; Ensure PATH works both in guix and within the debian chroot
+ ;; workaround for: https://bugs.debian.org/929889
+ (substitute* "functions"
+ (("PATH=/sbin:/usr/sbin:/bin:/usr/bin")
+ "PATH=$PATH:/sbin:/usr/sbin:/bin:/usr/bin"))
(substitute* (find-files "scripts" ".")
(("/usr/share/zoneinfo") (string-append tzdata "/share/zoneinfo")))
#t)))
@@ -184,9 +189,5 @@ contains the archive keys used for that.")
(description "Debootstrap is used to create a Debian base system from
scratch, without requiring the availability of @code{dpkg} or @code{apt}.
It does this by downloading .deb files from a mirror site, and carefully
-unpacking them into a directory which can eventually be chrooted into.
-
-It is recommended to run @code{debootstrap --foreign --arch=...} and then
-@code{chroot} into the directory, set the PATH and run @code{debootstrap
---second-stage} after.")
+unpacking them into a directory which can eventually be chrooted into.")
(license license:gpl2)))