summaryrefslogtreecommitdiff
path: root/gnu/packages/dc.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-01-24 18:36:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-25 16:20:23 +0100
commit28fb9101d940fee615f46fbf6c61299a64ae28c6 (patch)
treeb3832c97875b18743f8f766e983b53b1348d4976 /gnu/packages/dc.scm
parent9e55f04a4bb5b9d4f468d50c1ce8e19e8b0d0bd8 (diff)
downloadguix-patches-28fb9101d940fee615f46fbf6c61299a64ae28c6.tar
guix-patches-28fb9101d940fee615f46fbf6c61299a64ae28c6.tar.gz
gnu: Add ncdc-1.18.1.
* gnu/packages/dc.scm : New module. * gnu-system.am (GNU_SYSTEM_MODULES): Add module. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/dc.scm')
-rw-r--r--gnu/packages/dc.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/dc.scm b/gnu/packages/dc.scm
new file mode 100644
index 0000000000..75ed5f4af7
--- /dev/null
+++ b/gnu/packages/dc.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dc)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnutls)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages sqlite)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:)))
+
+(define-public ncdc
+ (package
+ (name "ncdc")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "11c6z9c3vv2vg01q02r53m28q3cx6x66j1l63f1mbk1crlqpf9fc"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("glib" ,glib)
+ ("gnutls" ,gnutls)
+ ("ncurses" ,ncurses)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://dev.yorhel.nl/ncdc")
+ (synopsis
+ "Lightweight direct connect client with a friendly ncurses interface")
+ (description
+ "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
+using ncurses. It is known for its smaller footprint and ease of use.")
+ (license license:x11)))