summaryrefslogtreecommitdiff
path: root/gnu/packages/dbm.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-08-22 14:48:33 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 17:32:26 +0100
commit63539587bc63e1be0a838ba2230c73774dd18ffe (patch)
treecd7a01bf8f93ce911c183cea03fe489551b93458 /gnu/packages/dbm.scm
parent213e1764f4acf158cf470534c4c5fccfe0a92cb5 (diff)
downloadguix-patches-63539587bc63e1be0a838ba2230c73774dd18ffe.tar
guix-patches-63539587bc63e1be0a838ba2230c73774dd18ffe.tar.gz
gnu: bdb: Fix cross-compilation.
* gnu/packages/dbm.scm (bdb-4.8)[arguments]: Pass host argument to configure when cross-compiling.
Diffstat (limited to 'gnu/packages/dbm.scm')
-rw-r--r--gnu/packages/dbm.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/dbm.scm b/gnu/packages/dbm.scm
index 5191c475c2..84c5817a79 100644
--- a/gnu/packages/dbm.scm
+++ b/gnu/packages/dbm.scm
@@ -55,7 +55,7 @@
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key target outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(doc (assoc-ref outputs "doc")))
;; '--docdir' is not honored, so we need to patch.
@@ -74,6 +74,10 @@
'("--build=aarch64-unknown-linux-gnu")
'())
+ ,@(if (%current-target-system) ; cross building
+ '((string-append "--host=" target))
+ '())
+
;; Remove 7 MiB of .a files.
"--disable-static"