summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 20:25:07 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 20:26:05 -0400
commitf76af41a768512376d770c833e5317ff90d30cf2 (patch)
treebdf3e80f7095c7513a11d6824cb44b4de116cd40 /gnu/packages/dav.scm
parent2f87a77ff7fcd83c2de6b513eb49819e17232d95 (diff)
downloadguix-patches-f76af41a768512376d770c833e5317ff90d30cf2.tar
guix-patches-f76af41a768512376d770c833e5317ff90d30cf2.tar.gz
gnu: radicale: Run the test suite with py.test.
* gnu/packages/dav.scm (radicale)[native-inputs]: Add python-pytest. [arguments]: Replace the 'check' phase and run the tests with python-pytest.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index be6c40f4ba..ba56d0d852 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -34,6 +34,14 @@
(base32
"1c5lv8qca21mndkx350wxv34qypqh6gb4rhzms4anr642clq3jg2"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "py.test")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(propagated-inputs
;; TODO: Add python-pam
`(("python-requests" ,python-requests)))