summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-30 00:15:35 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commitf75bbb028a5f63c62136fd6345fa146bcb038691 (patch)
tree6df25b73833d449317d0be4918b076cced1fa25a /gnu/packages/dav.scm
parent89b8a5516fe3c72befc256652cfb27cb41a4f977 (diff)
downloadguix-patches-f75bbb028a5f63c62136fd6345fa146bcb038691.tar
guix-patches-f75bbb028a5f63c62136fd6345fa146bcb038691.tar.gz
gnu: Add radicale.
* gnu/packages/dav.scm (radicale): New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
new file mode 100644
index 0000000000..b22aff6580
--- /dev/null
+++ b/gnu/packages/dav.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dav)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (gnu packages python))
+
+(define-public radicale
+ (package
+ (name "radicale")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Radicale" version))
+ (sha256
+ (base32
+ "1c5lv8qca21mndkx350wxv34qypqh6gb4rhzms4anr642clq3jg2"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ ;; TODO: Add python-pam
+ `(("python-requests" ,python-requests)))
+ (synopsis "Basic CalDAV and CardDAV server")
+ (description "Radicale is a CalDAV and CardDAV server for UNIX-like
+platforms. Calendars and address books are available for both local and remote
+access, possibly limited through authentication policies. They can be viewed
+and edited by calendar and contact clients on mobile phones or computers.
+
+Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
+Instead, it supports the CalDAV and CardDAV implementations of popular
+clients.")
+ (home-page "http://radicale.org/")
+ (license gpl3+)))