summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-10 11:03:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:25 +0100
commita08a8350343145b18301ba0926787c0e28ee24fc (patch)
tree1613b8f6b6a518f72510cb5fb888df7ba7a476c9 /gnu/packages/dav.scm
parenteee5cd04405dc499fcdce20f9219a9bded5720ce (diff)
downloadguix-patches-a08a8350343145b18301ba0926787c0e28ee24fc.tar
guix-patches-a08a8350343145b18301ba0926787c0e28ee24fc.tar.gz
gnu: vdirsyncer: Fix build by setting correct PYTHONPATH.
For thus, use add-installed-pythonpath. * gnu/packages/dav.scm (vdirsyncer): set PYTHONPATH using add-installed-pythonpath.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 835b8fcf39..a06878dc92 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -73,11 +73,8 @@ clients.")
;; vdirsyncer requires itself to be installed in order to build
;; the manpage.
(add-after 'install 'manpage
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "PYTHONPATH"
- (string-append
- (getenv "PYTHONPATH")
- ":" (assoc-ref outputs "out")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
(zero? (system* "make" "--directory=docs/" "man"))
(install-file
"docs/_build/man/vdirsyncer.1"