summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:08:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:08:01 +0300
commit9af7469c5b6bfb3423529deefc2bdc1dadf4091e (patch)
treedd0f2ca81ec847530294550fbb11b5db64f05519 /gnu/packages/dav.scm
parentc5b63846b8c9467c403345f89cb16cfea9832555 (diff)
downloadguix-patches-9af7469c5b6bfb3423529deefc2bdc1dadf4091e.tar
guix-patches-9af7469c5b6bfb3423529deefc2bdc1dadf4091e.tar.gz
gnu: vdirsyncer: Return #t from all phases.
* gnu/packages/dav.scm (vdirsyncer)[arguments]: Substitute invoke for system*.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 2b1d55c8a5..9aebc5568d 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,22 +67,23 @@ clients.")
"07iqq5c53cfrb5xnmam1rsl683hc3rykmdak896n2gm81r361c66"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (setenv "DETERMINISTIC_TESTS" "true")
- (setenv "DAV_SERVER" "radicale")
- (setenv "REMOTESTORAGE_SERVER" "skip")
- (zero? (system* "make" "test"))))
- (add-after 'install 'manpage
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "make" "--directory=docs/" "man"))
- (install-file
- "docs/_build/man/vdirsyncer.1"
- (string-append
- (assoc-ref outputs "out")
- "/share/man/man1")))))))
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (setenv "DETERMINISTIC_TESTS" "true")
+ (setenv "DAV_SERVER" "radicale")
+ (setenv "REMOTESTORAGE_SERVER" "skip")
+ (invoke "make" "test")))
+ (add-after 'install 'manpage
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "make" "--directory=docs/" "man")
+ (install-file
+ "docs/_build/man/vdirsyncer.1"
+ (string-append
+ (assoc-ref outputs "out")
+ "/share/man/man1"))
+ #t)))))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)
("python-sphinx" ,python-sphinx)