summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-18 09:53:44 -0500
committerLeo Famulari <leo@famulari.name>2017-02-18 10:24:03 -0500
commit945b6721ebe4ba61396d5e618a76ae3f0199271a (patch)
tree0f824b92729252ebd4055f4c239e96ce056b05f9 /gnu/packages/dav.scm
parent1ba67b6286726c86033cb061c29f4864510cf553 (diff)
downloadguix-patches-945b6721ebe4ba61396d5e618a76ae3f0199271a.tar
guix-patches-945b6721ebe4ba61396d5e618a76ae3f0199271a.tar.gz
gnu: vdirsyncer: Don't fail the test suite when the build machine is slow.
* gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/dav.scm (vdirsyncer)[source]: Use it.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index dd03d8964b..908b336f8c 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +21,7 @@
#:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix packages)
+ #:use-module (gnu packages)
#:use-module (gnu packages python))
(define-public radicale
@@ -58,6 +59,8 @@ clients.")
(source (origin
(method url-fetch)
(uri (pypi-uri name version))
+ (patches
+ (search-patches "vdirsyncer-test-suite-slow-machines.patch"))
(sha256
(base32
"044f01fjd8dpz4y9dm3qcc1a8cihcxxbr1sz6y6fkvglpb6k85y5"))))