summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-30 17:55:04 -0500
committerLeo Famulari <leo@famulari.name>2016-02-02 14:49:26 -0500
commit8c44dabc5a54e51cca2b217899438b1055c09d59 (patch)
tree599470eaf99c4c6e727592bd23fb2a9fa4708751 /gnu/packages/dav.scm
parent7517e73c7511afacacd49178ca84f0468e9beb2c (diff)
downloadguix-patches-8c44dabc5a54e51cca2b217899438b1055c09d59.tar
guix-patches-8c44dabc5a54e51cca2b217899438b1055c09d59.tar.gz
gnu: vdirsyncer: Update to 0.8.1.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.8.1. [native-inputs]: Add python-hypothesis, python-pytest-subtesthack.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index f13d013d50..25b665f292 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,13 +52,13 @@ clients.")
(define-public vdirsyncer
(package
(name "vdirsyncer")
- (version "0.7.5")
+ (version "0.8.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "vdirsyncer" version))
(sha256
(base32
- "0dvar4k95n689fgw5gy19mb7ggaw32c8j2gbglr33wn7pbxc2l9z"))))
+ "1abflqw6x30xd2dlj58cr5n62x98kc0ia9f9vr8l64k2z1fjlq78"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -86,8 +86,10 @@ clients.")
("python-setuptools-scm" ,python-setuptools-scm)
("python-sphinx" ,python-sphinx)
;; Required for testing
+ ("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("python-pytest-localserver" ,python-pytest-localserver)
+ ("python-pytest-subtesthack" ,python-pytest-subtesthack)
("python-pytest-xprocess" ,python-pytest-xprocess)
("python-wsgi-intercept" ,python-wsgi-intercept)
("radicale" ,radicale)))