summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-27 18:00:24 -0300
committerLeo Famulari <leo@famulari.name>2020-08-27 17:18:52 -0400
commit828658f8fe6721215dbe5fd49702ae63121a8573 (patch)
treeee0d6c92a0f192807c36db30fd16a357ee327b00 /gnu/packages/dav.scm
parentf6ac084d4f0311effeb2ffe0411b86e504602051 (diff)
downloadguix-patches-828658f8fe6721215dbe5fd49702ae63121a8573.tar
guix-patches-828658f8fe6721215dbe5fd49702ae63121a8573.tar.gz
gnu: radicale: Update to 3.0.4.
* gnu/packages/dav.scm (radicale): Update to 3.0.4. [source]: Use git-fetch. [arguments]: Run the test suite. [native-inputs]: Add python-pytest, python-pytest-cov, python-pytest-flake8, python-pytest-isort, python-pytest-runner, python-waitress. [propagated-inputs]: Remove python-requests. Add python-dateutil, python-defusedxml, python-passlib, python-vobject. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm37
1 files changed, 26 insertions, 11 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index ab50c86f14..8692a49c50 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -24,30 +24,45 @@
#:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix packages)
+ #:use-module (guix git-download)
#:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages time)
#:use-module (gnu packages xml))
(define-public radicale
(package
(name "radicale")
- (version "1.1.6")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Radicale" version))
- (sha256
- (base32
- "0ay90nj6fmr2aq8imi0mbjl4m2rzq7a83ikj8qs9gxsylj71j1y0"))))
+ (version "3.0.4")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Kozea/Radicale")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hj9mmhrj32mzhxlnjcfijb7768cyjsn603nalp54clgb2gkmvw8"))))
(build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; The tests are not distributed in the PyPi release.
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-pytest-isort" ,python-pytest-isort)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-waitress" ,python-waitress)))
(propagated-inputs
- ;; TODO: Add python-pam
- `(("python-requests" ,python-requests)))
+ `(("python-dateutil" ,python-dateutil)
+ ("python-defusedxml" ,python-defusedxml)
+ ("python-passlib" ,python-passlib)
+ ("python-vobject" ,python-vobject)))
(synopsis "Basic CalDAV and CardDAV server")
(description "Radicale is a CalDAV and CardDAV server for UNIX-like
platforms. Calendars and address books are available for both local and remote