summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-04 12:21:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-04 12:21:45 +0300
commit0c34b9494333fb355d288a0165b85cb3c1c2a628 (patch)
treecef65f6eb48822489822bbdff2d869b7b4d8982b /gnu/packages/dav.scm
parent57ec0551c8a360c592a8ecdd3ad30d315353a3d0 (diff)
downloadguix-patches-0c34b9494333fb355d288a0165b85cb3c1c2a628.tar
guix-patches-0c34b9494333fb355d288a0165b85cb3c1c2a628.tar.gz
gnu: vdirsyncer: Skip tests.
* gnu/packages/dav.scm (vdirsyncer)[arguments]: Disable tests. Update custom 'check phase to only run the tests when enabled.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 3b040028a1..fb370fd716 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,14 +69,17 @@ clients.")
"1vqjhn2bffy2bx45a1r14crsyn2cylf5by567g44c4mhpjwwz6vc"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:tests? #f ; The test suite is very flakey.
+ #:phases (modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(setenv "DETERMINISTIC_TESTS" "true")
(setenv "DAV_SERVER" "radicale")
(setenv "REMOTESTORAGE_SERVER" "skip")
- (invoke "make" "test")))
+ (if tests?
+ (invoke "make" "test")
+ #t)))
(add-after 'install 'manpage
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "make" "--directory=docs/" "man")