summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-08 19:45:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-12 05:12:13 +0100
commitcc3ac162c558a51c90b76b84b081a15e28d0baad (patch)
treed524d7a5deece25ce1cd1df74a530ca8acfa727c /gnu/packages/datastructures.scm
parent8d8d227bbbe9bd1981bc63704c7f3fe029001f53 (diff)
downloadguix-patches-cc3ac162c558a51c90b76b84b081a15e28d0baad.tar
guix-patches-cc3ac162c558a51c90b76b84b081a15e28d0baad.tar.gz
gnu: Add uthash.
* gnu/packages/datastructures.scm (uthash): New public variable.
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 36318ee04e..0c751f4970 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -116,3 +116,58 @@ with the number of cores. liburcu-cds provides efficient data structures
based on RCU and lock-free algorithms. These structures include hash tables,
queues, stacks, and doubly-linked lists.")
(license license:lgpl2.1+)))
+
+(define-public uthash
+ (package
+ (name "uthash")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/troydhanson/uthash/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1la82gdlyl7m8ahdjirigwfh7zjgkc24cvydrqcri0vsvm8iv8rl"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; nothing to configure
+ (delete 'build) ; nothing to build
+ (replace 'check
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (with-directory-excursion "tests"
+ (zero? (apply system* "make"
+ make-flags)))))
+ (replace 'install
+ ;; There is no top-level Makefile to do this for us.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name))
+ (include (string-append out "/include")))
+ ;; Don't install HTML files: they're just the below .txt files
+ ;; dolled up, can be stale, and regeneration requires asciidoc.
+ (for-each (λ (file) (install-file file doc))
+ (find-files "doc" "\\.txt$"))
+ (for-each (λ (file) (install-file file include))
+ (find-files "src" "\\.h$"))
+ #t))))))
+ (home-page "https://troydhanson.github.io/uthash/")
+ (synopsis
+ "Hash tables, lists, and other data structures implemented as C macros")
+ (description
+ "uthash implements a hash table and a few other basic data structures
+as C preprocessor macros. It aims to be minimalistic and efficient: it's
+around 1,000 lines of code which, being macros, inline automatically.
+
+Unlike function calls with fixed prototypes, macros operate on untyped
+arguments. Thus, they are able to work with any type of structure and key.
+Any C structure can be stored in a hash table by adding @code{UT_hash_handle}
+to the structure and choosing one or more fields to act as the key.")
+ (license license:bsd-2)))