summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-10-30 16:32:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-17 02:32:00 +0100
commit754667f0eb44491370a2ec4fa0b4705cfcf6d237 (patch)
tree7bd3e7de171f7da75e40273094593ba1a87a37b7 /gnu/packages/datastructures.scm
parent366efcb2fbc78c7fdeabf795f4d27ccfcf61c8a4 (diff)
downloadguix-patches-754667f0eb44491370a2ec4fa0b4705cfcf6d237.tar
guix-patches-754667f0eb44491370a2ec4fa0b4705cfcf6d237.tar.gz
gnu: Add liburcu.
* gnu/packages/datastructures.scm (liburcu): New variable.
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index b9e6061238..ef249b9659 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +19,7 @@
(define-module (gnu packages datastructures)
#:use-module (gnu packages)
+ #:use-module (gnu packages perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -92,3 +93,26 @@ hashes (CTPH), also called fuzzy checksums. It can identify similar files
that have sequences of identical bytes in the same order, even though bytes
in between these sequences may be different in both content and length.")
(license license:gpl2+)))
+
+(define-public liburcu
+ (package
+ (name "liburcu")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.lttng.org/files/urcu/"
+ "userspace-rcu-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "01j0xp3f0w147yfyzybkjvb7i67i7prsvnkssgvgwry9lvk35khv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl))) ; for tests
+ (home-page "http://liburcu.org/")
+ (synopsis "User-space RCU data synchronisation library")
+ (description "liburcu is a user-space @dfn{Read-Copy-Update} (RCU) data
+synchronisation library. It provides read-side access that scales linearly
+with the number of cores. liburcu-cds provides efficient data structures
+based on RCU and lock-free algorithms. These structures include hash tables,
+queues, stacks, and doubly-linked lists.")
+ (license license:lgpl2.1+)))