summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-07-19 04:05:29 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-19 23:03:30 +0200
commit592ccdd38850d581f669f834f051ee8f92d7ee31 (patch)
tree5ff77ce163fbc98f4dfcd346d653dcabfcccf6c9 /gnu/packages/datastructures.scm
parent7fe3f8cf6ef0fb220267caca616aadc5d5e28608 (diff)
downloadguix-patches-592ccdd38850d581f669f834f051ee8f92d7ee31.tar
guix-patches-592ccdd38850d581f669f834f051ee8f92d7ee31.tar.gz
gnu: Add ssdeep.
* gnu/packages/datastructures.scm (ssdeep): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 74b9fff4af..b9e6061238 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,3 +71,24 @@ probing. This method is space-efficient -- there is no pointer overhead --
and time-efficient for good hash functions.")
(home-page "https://github.com/sparsehash/sparsehash")
(license license:bsd-3)))
+
+(define-public ssdeep
+ (package
+ (name "ssdeep")
+ (version "2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ssdeep/"
+ name "-" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1igqy0j7jrklb8fdlrm6ald4cyl1fda5ipfl8crzyl6bax2ajk3f"))))
+ (build-system gnu-build-system)
+ (home-page "http://ssdeep.sourceforge.net")
+ (synopsis "Context-triggered piecewise hashing algorithm")
+ (description "ssdeep computes and matches context triggered piecewise
+hashes (CTPH), also called fuzzy checksums. It can identify similar files
+that have sequences of identical bytes in the same order, even though bytes
+in between these sequences may be different in both content and length.")
+ (license license:gpl2+)))