summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 21:38:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:33 -0500
commitf72c4f3dca3f5b6ece654c22f098e9f8c3838931 (patch)
tree993bfea518880165ec43fff07f57d79c12b28eb5 /gnu/packages/databases.scm
parentd9cef9390ca46fe0572abde7117e6454a235c40c (diff)
downloadguix-patches-f72c4f3dca3f5b6ece654c22f098e9f8c3838931.tar
guix-patches-f72c4f3dca3f5b6ece654c22f098e9f8c3838931.tar.gz
gnu: Add python-pypika-tortoise.
* gnu/packages/databases.scm (python-pypika-tortoise): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7bcc01411d..cc73328e76 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2591,6 +2591,24 @@ can autogenerate peewee models using @code{pwiz}, a model generator.")
(define-public python2-peewee
(package-with-python2 python-peewee))
+(define-public python-pypika-tortoise
+ (package
+ (name "python-pypika-tortoise")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pypika-tortoise" version))
+ (sha256
+ (base32 "0g4z0lz739nk04b405ynqpd3y1z5nfyxjz9hqgxcw3jydsjx0cb8"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/tortoise/pypika-tortoise")
+ (synopsis "Pypika fork for tortoise-orm")
+ (description "Pypika-tortoise is a fork of pypika which has been
+streamlined for its use in the context of tortoise-orm. It removes support
+for many database kinds that tortoise-orm doesn't need, for example.")
+ (license license:asl2.0)))
+
(define-public python-tortoise-orm
(package
(name "python-tortoise-orm")