summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-05-17 14:50:04 -0400
committerLeo Famulari <leo@famulari.name>2021-05-17 15:05:14 -0400
commitef221c8b7117a19e9d60644953ed8a71b9601d8c (patch)
tree530e09d3508370ef2106c658c6da9db2384b312b /gnu/packages/databases.scm
parent946dd6103a843b48e828addae53c240077c2221a (diff)
downloadguix-patches-ef221c8b7117a19e9d60644953ed8a71b9601d8c.tar
guix-patches-ef221c8b7117a19e9d60644953ed8a71b9601d8c.tar.gz
gnu: PostgreSQL: Update to 13.3 [fixes CVE-2021-{32027,32028,32029}].
* gnu/packages/databases.scm (postgresql-13)[replacement]: Use postgresql-13.3. (postgresql-13.2): Replace with ... (postgresql-13.3): ... new variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8907c40166..f51d1921f1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1035,7 +1035,7 @@ and high-availability (HA).")
(define-public postgresql-13
(package
(name "postgresql")
- (replacement postgresql-13.2)
+ (replacement postgresql-13.3)
(version "13.1")
(source (origin
(method url-fetch)
@@ -1084,18 +1084,18 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
-(define-public postgresql-13.2
+(define-public postgresql-13.3
(package
(inherit postgresql-13)
(name "postgresql")
- (version "13.2")
+ (version "13.3")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "1z5d847jnajcfr3wa6jn52a8xjhamvwzmz18xlm5nvxqip8grmsz"))
+ "18dliq7h2l8irffhyyhdmfwx3si515q6gds3cxdjb9n7m17lbn9w"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
(define-public postgresql-11